Bug 227610 - After ajax call the browser refreshes site when it is using response variable
Summary: After ajax call the browser refreshes site when it is using response variable
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: Safari 14
Hardware: iPhone / iPad iOS 14
: P2 Major
Assignee: Nobody
URL: https://template.neptune-software.com...
Keywords:
: 227625 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-01 23:01 PDT by dominik.beffar
Modified: 2021-07-07 11:35 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dominik.beffar 2021-07-01 23:01:09 PDT
https://template.neptune-software.com/neptune/sdk/EXP_SAMPLE_ODATA_JSONH_V4

When calling this site on mobile and starting the ajax call, everything works out,
till the call reaches the javascript with the response.
Then at the first time when using the response variable it crashes.
It says webkit encountered internal error.
But the response is fine, it happens with every ajax response above some thousands of entries.
Its working on desktop and other, just on iOS in Safari not.
Comment 1 Alexey Proskuryakov 2021-07-07 11:29:13 PDT
This website is attempting to use more RAM than is allowed for WebContent process on iOS (reaching ~2.5 GB on a Mac). So it is expected behavior that it is getting terminated by the OS.
Comment 2 Alexey Proskuryakov 2021-07-07 11:35:42 PDT
*** Bug 227625 has been marked as a duplicate of this bug. ***