Bug 22752 - Clear SymbolTable after codegen for Function codeblocks that don't require an activation
Summary: Clear SymbolTable after codegen for Function codeblocks that don't require an...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-08 22:00 PST by Sam Weinig
Modified: 2008-12-09 16:42 PST (History)
0 users

See Also:


Attachments
patch (3.04 KB, patch)
2008-12-08 22:03 PST, Sam Weinig
no flags Details | Formatted Diff | Diff
updated patch (3.11 KB, patch)
2008-12-09 16:39 PST, Sam Weinig
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Weinig 2008-12-08 22:00:23 PST
Only codeblocks for functions that need an activation, which we can determine statically, need to keep their SymbolTable around after codegen.
Comment 1 Sam Weinig 2008-12-08 22:03:59 PST
Created attachment 25873 [details]
patch
Comment 2 Cameron Zwarich (cpst) 2008-12-08 22:05:51 PST
Comment on attachment 25873 [details]
patch

r=me
Comment 3 Cameron Zwarich (cpst) 2008-12-08 22:19:37 PST
Oliver just pointed out that this will cause problems for the debugger -- you should check needsFullScopeChain on the CodeBlock instead, since that also includes the case of debugging.
Comment 4 Oliver Hunt 2008-12-08 23:25:30 PST
Comment on attachment 25873 [details]
patch

removing r+ flag due to regression Sam found -- f.arguments.argumentName fails :-(
Comment 5 Sam Weinig 2008-12-09 16:39:22 PST
Created attachment 25903 [details]
updated patch
Comment 6 Sam Weinig 2008-12-09 16:42:08 PST
Fixed in r39157.