Bug 227478 - [css-scroll-snap] Triggering a layout during scroll causes jittery scrolling on Mac when dragging the scrollbar
Summary: [css-scroll-snap] Triggering a layout during scroll causes jittery scrolling ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: Safari Technology Preview
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Martin Robinson
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-06-29 01:47 PDT by Martin Robinson
Modified: 2021-07-29 10:50 PDT (History)
2 users (show)

See Also:


Attachments
Test case (1.15 KB, text/html)
2021-06-29 01:48 PDT, Martin Robinson
no flags Details
Patch (13.44 KB, patch)
2021-07-01 04:36 PDT, Martin Robinson
no flags Details | Formatted Diff | Diff
Patch (14.47 KB, patch)
2021-07-02 03:25 PDT, Martin Robinson
no flags Details | Formatted Diff | Diff
Patch (14.42 KB, patch)
2021-07-05 01:32 PDT, Martin Robinson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2021-06-29 01:47:36 PDT
When a page trigger layout during scroll events and with scroll snap, dragging the scrollbar on a Mac causes a lot of jitter while scrolling. The issue is that during layout the code is trying to snap. Each new movement of the scroll bar unsnaps briefly and then the relayout snaps again.
Comment 1 Martin Robinson 2021-06-29 01:48:16 PDT
Created attachment 432460 [details]
Test case
Comment 2 Martin Robinson 2021-07-01 04:36:08 PDT
Created attachment 432678 [details]
Patch
Comment 3 Martin Robinson 2021-07-02 03:25:13 PDT
Created attachment 432774 [details]
Patch
Comment 4 Martin Robinson 2021-07-05 01:32:15 PDT
Created attachment 432874 [details]
Patch
Comment 5 EWS 2021-07-05 02:21:12 PDT
Committed r279564 (239395@main): <https://commits.webkit.org/239395@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 432874 [details].
Comment 6 Radar WebKit Bug Importer 2021-07-05 02:22:18 PDT
<rdar://problem/80168708>