Bug 227147 - Define MacroAssemblerARM64E::numberOfPACBits based on OS_CONSTANT(EFFECTIVE_ADDRESS_WIDTH).
Summary: Define MacroAssemblerARM64E::numberOfPACBits based on OS_CONSTANT(EFFECTIVE_A...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-06-17 14:45 PDT by Mark Lam
Modified: 2021-06-17 18:45 PDT (History)
9 users (show)

See Also:


Attachments
proposed patch. (14.10 KB, patch)
2021-06-17 14:57 PDT, Mark Lam
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
proposed patch. (17.42 KB, patch)
2021-06-17 15:28 PDT, Mark Lam
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
proposed patch. (18.01 KB, patch)
2021-06-17 15:39 PDT, Mark Lam
saam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2021-06-17 14:45:38 PDT
Also define OS_CONSTANT(EFFECTIVE_ADDRESS_WIDTH) based on MACH_VM_MAX_ADDRESS for OS(DARWIN).

rdar://78785309
Comment 1 Mark Lam 2021-06-17 14:57:29 PDT
Created attachment 431725 [details]
proposed patch.
Comment 2 Mark Lam 2021-06-17 15:28:45 PDT
Created attachment 431729 [details]
proposed patch.
Comment 3 Mark Lam 2021-06-17 15:39:44 PDT
Created attachment 431731 [details]
proposed patch.
Comment 4 Saam Barati 2021-06-17 16:01:13 PDT
Comment on attachment 431731 [details]
proposed patch.

View in context: https://bugs.webkit.org/attachment.cgi?id=431731&action=review

> Source/WTF/wtf/CagedPtr.h:48
> +    static constexpr unsigned numberOfPACBits = numberOfPointerBits - OS_CONSTANT(EFFECTIVE_ADDRESS_WIDTH);

would be good if we eventually renamed this to "maximumNumberOfAllowedPACBits" or similar
Comment 5 Mark Lam 2021-06-17 16:02:05 PDT
(In reply to Saam Barati from comment #4)
> Comment on attachment 431731 [details]
> proposed patch.
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=431731&action=review
> 
> > Source/WTF/wtf/CagedPtr.h:48
> > +    static constexpr unsigned numberOfPACBits = numberOfPointerBits - OS_CONSTANT(EFFECTIVE_ADDRESS_WIDTH);
> 
> would be good if we eventually renamed this to
> "maximumNumberOfAllowedPACBits" or similar

I can do that in a follow up patch.
Comment 6 Mark Lam 2021-06-17 18:45:53 PDT
Thanks for the review.  Landed in r279028: <http://trac.webkit.org/r279028>.