Keeping a pointer allowed for some syntactic sugar - "link()" looks nicer than "link(this)". But maintaining this doubles the size of Jump, which is even more unfortunate for the JIT, since there are many large structures holding JmpSrcs. Probably best to remove it.
Created attachment 25787 [details]
Comment on attachment 25787 [details]
Transmitting file data .....
Committed revision 39043.