Drop Checked::safeGet() and replace with uses of Checked::operator T() or Checked::value().
Created attachment 430355 [details]
Created attachment 430361 [details]
Comment on attachment 430361 [details]
Looks good. In future code we write, I hope people will not need pairs of checked and unchecked local variables; just use Checked<> and it will typically do the right thing without naming everything xxxChecked.
By the way, I think the syntax Checked<uint32_t> will be better than CheckedUint32 some day, so I hope we can later move to that. For now, I think moving to the aliases is better, but I don’t think we need modes other than RecordOverflow. Presumably the "crash right away when we overflow" mode is there for optimization reasons, but it seems unnecessary. Seems like it would always be fine to crash when you go to fetch the value rather than eagerly crashing while doing the math.
Committed r278369 (238396@main): <https://commits.webkit.org/238396@main>
All reviewed patches have been landed. Closing bug and clearing flags on attachment 430361 [details].