Bug 226505 - REGRESSION: (r277971) TestWebKitAPI.WebKit.AccessibilityReduceMotion is timing out
Summary: REGRESSION: (r277971) TestWebKitAPI.WebKit.AccessibilityReduceMotion is timin...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: chris fleizach
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-06-01 10:37 PDT by Truitt Savell
Modified: 2021-06-07 22:46 PDT (History)
6 users (show)

See Also:


Attachments
patch (3.04 KB, patch)
2021-06-01 16:37 PDT, chris fleizach
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Truitt Savell 2021-06-01 10:37:37 PDT
It looks like the changes in https://trac.webkit.org/changeset/277971/webkit

broke TestWebKitAPI.WebKit.AccessibilityReduceMotion and is now timing out

history:
https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.WebKit.AccessibilityReduceMotion
Comment 1 Radar WebKit Bug Importer 2021-06-01 10:37:50 PDT
<rdar://problem/78721462>
Comment 2 chris fleizach 2021-06-01 16:37:46 PDT
Created attachment 430304 [details]
patch
Comment 3 EWS 2021-06-01 17:27:51 PDT
Committed r278334 (238367@main): <https://commits.webkit.org/238367@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 430304 [details].
Comment 4 Aakash Jain 2021-06-07 06:35:56 PDT
(In reply to EWS from comment #3)
> Committed r278334 (238367@main): <https://commits.webkit.org/238367@main>
This test is now failing on iOS since this change, as also warned by api-ios ews.
 
History: https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.WebKit.AccessibilityReduceMotion
Comment 5 chris fleizach 2021-06-07 22:30:39 PDT
(In reply to Aakash Jain from comment #4)
> (In reply to EWS from comment #3)
> > Committed r278334 (238367@main): <https://commits.webkit.org/238367@main>
> This test is now failing on iOS since this change, as also warned by api-ios
> ews.
>  
> History:
> https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.WebKit.
> AccessibilityReduceMotion

Working on it...
Comment 6 chris fleizach 2021-06-07 22:46:47 PDT
(In reply to chris fleizach from comment #5)
> (In reply to Aakash Jain from comment #4)
> > (In reply to EWS from comment #3)
> > > Committed r278334 (238367@main): <https://commits.webkit.org/238367@main>
> > This test is now failing on iOS since this change, as also warned by api-ios
> > ews.
> >  
> > History:
> > https://results.webkit.org/?suite=api-tests&test=TestWebKitAPI.WebKit.
> > AccessibilityReduceMotion
> 
> Working on it...

https://bugs.webkit.org/show_bug.cgi?id=226758