Bug 22625 - REGRESSION: Form onsubmit handler is not invoked after going back
Summary: REGRESSION: Form onsubmit handler is not invoked after going back
Status: RESOLVED DUPLICATE of bug 22562
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2008-12-03 05:36 PST by Alexey Proskuryakov
Modified: 2008-12-11 22:29 PST (History)
0 users

See Also:


Attachments
test case (656 bytes, text/html)
2008-12-03 05:37 PST, Alexey Proskuryakov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2008-12-03 05:36:46 PST
When going back to a page that submitted a form, and trying to submit it again, the form's onsubmit handler is not invoked.

This is a regression from Safari 3.2.1.
Comment 1 Alexey Proskuryakov 2008-12-03 05:37:03 PST
Created attachment 25708 [details]
test case
Comment 2 Alexey Proskuryakov 2008-12-03 05:39:23 PST
<rdar://problem/6414581>
Comment 3 Alexey Proskuryakov 2008-12-03 05:48:58 PST
See also: bug 22562.
Comment 4 Cameron Zwarich (cpst) 2008-12-11 22:29:51 PST

*** This bug has been marked as a duplicate of 22562 ***