RESOLVED FIXED 225571
Remove calls to the String::toInt family of functions from JavaScriptCore
https://bugs.webkit.org/show_bug.cgi?id=225571
Summary Remove calls to the String::toInt family of functions from JavaScriptCore
Darin Adler
Reported 2021-05-08 18:23:29 PDT
Remove calls to the String::toInt family of functions from JavaScriptCore
Attachments
Patch (6.98 KB, patch)
2021-05-08 18:26 PDT, Darin Adler
sam: review+
darin: commit-queue-
Darin Adler
Comment 1 2021-05-08 18:26:09 PDT
Darin Adler
Comment 2 2021-05-08 19:06:43 PDT
Style checker is complaining that I am using the word fuzzer in the change log. This is very silly since it’s in the file name of a file I am modifying.
Sam Weinig
Comment 3 2021-05-08 19:16:54 PDT
Comment on attachment 428105 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=428105&action=review > Source/JavaScriptCore/ChangeLog:10 > + (Inspector::parseLocation): Use parseIntegerAllowingTrailingJunk<uintptr_t> instead of > + String::toIntPtr. Why the change from intptr_t to uintptr_t here?
Darin Adler
Comment 4 2021-05-08 20:42:17 PDT
Comment on attachment 428105 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=428105&action=review >> Source/JavaScriptCore/ChangeLog:10 >> + String::toIntPtr. > > Why the change from intptr_t to uintptr_t here? Unintentional. I will change it back.
Darin Adler
Comment 5 2021-05-08 21:13:16 PDT
Comment on attachment 428105 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=428105&action=review >>> Source/JavaScriptCore/ChangeLog:10 >>> + String::toIntPtr. >> >> Why the change from intptr_t to uintptr_t here? > > Unintentional. I will change it back. Actually, the type is JSC::SourceID, not intptr_t and not uintptr_t either. I am changing to that.
Darin Adler
Comment 6 2021-05-08 21:15:29 PDT
Radar WebKit Bug Importer
Comment 7 2021-05-08 21:16:25 PDT
Note You need to log in before you can comment on or make changes to this bug.