Bug 225249 - Make the JIT pool smaller on AS
Summary: Make the JIT pool smaller on AS
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: Other
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords: InRadar
: 209037 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-04-30 14:07 PDT by Filip Pizlo
Modified: 2021-04-30 14:53 PDT (History)
7 users (show)

See Also:


Attachments
the patch (6.12 KB, patch)
2021-04-30 14:08 PDT, Filip Pizlo
sbarati: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2021-04-30 14:07:10 PDT
It improves perf a bit.
Comment 1 Filip Pizlo 2021-04-30 14:08:46 PDT
Created attachment 427445 [details]
the patch
Comment 2 Saam Barati 2021-04-30 14:23:27 PDT
Comment on attachment 427445 [details]
the patch

View in context: https://bugs.webkit.org/attachment.cgi?id=427445&action=review

> Source/JavaScriptCore/jit/ExecutableAllocator.cpp:336
> +    if (Options::executablePoolSizeOverride())
> +        reservation.size = Options::executablePoolSizeOverride();

this already exists right below. Just remove the ENABLE
Comment 3 Saam Barati 2021-04-30 14:25:39 PDT
Comment on attachment 427445 [details]
the patch

View in context: https://bugs.webkit.org/attachment.cgi?id=427445&action=review

> Source/JavaScriptCore/jit/ExecutableAllocator.cpp:409
> +        , m_numAllocators(numberOfRegions)

maybe we should rename numberOfRegions to  maxNumberOfRegions
Comment 4 Filip Pizlo 2021-04-30 14:29:41 PDT
*** Bug 209037 has been marked as a duplicate of this bug. ***
Comment 5 Filip Pizlo 2021-04-30 14:52:13 PDT
Landed in https://trac.webkit.org/changeset/276855/webkit
Comment 6 Radar WebKit Bug Importer 2021-04-30 14:53:31 PDT
<rdar://problem/77400108>