It improves perf a bit.
Created attachment 427445 [details] the patch
Comment on attachment 427445 [details] the patch View in context: https://bugs.webkit.org/attachment.cgi?id=427445&action=review > Source/JavaScriptCore/jit/ExecutableAllocator.cpp:336 > + if (Options::executablePoolSizeOverride()) > + reservation.size = Options::executablePoolSizeOverride(); this already exists right below. Just remove the ENABLE
Comment on attachment 427445 [details] the patch View in context: https://bugs.webkit.org/attachment.cgi?id=427445&action=review > Source/JavaScriptCore/jit/ExecutableAllocator.cpp:409 > + , m_numAllocators(numberOfRegions) maybe we should rename numberOfRegions to maxNumberOfRegions
*** Bug 209037 has been marked as a duplicate of this bug. ***
Landed in https://trac.webkit.org/changeset/276855/webkit
<rdar://problem/77400108>