Bug 225083 - REGRESSION (iOS 14.5): PWA's / Home Screen Apps with Service Workers intermittenly fail to open offline
Summary: REGRESSION (iOS 14.5): PWA's / Home Screen Apps with Service Workers intermit...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Service Workers (show other bugs)
Version: Safari 14
Hardware: iPhone / iPad iOS 14
: P2 Critical
Assignee: youenn fablet
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-04-26 18:48 PDT by mike
Modified: 2021-04-30 11:18 PDT (History)
6 users (show)

See Also:


Attachments
Patch (1.71 KB, patch)
2021-04-29 06:21 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mike 2021-04-26 18:48:00 PDT
On iOS/iPad OS 14.5 and 14.6 Beta, PWA/Home Screen Apps with Service Workers are intermittently failing to open when the iPad/iPhone is disconnected from the internet. Instead they return the error page: "Safari cannot open the page *web app url* because your iPad is not connected to the Internet" or "Safari cannot open the Page because your iPhone is not connected to the Internet". It is intermittent, and the Web App will usually open the first time after turning off the network, but eventually fail to open after closing and re-opening repeatedly. It seems to randomly open again if you keep trying, and will work in bursts (open offline perhaps 3 times in a row), before predominately failing to open again. I haven't been able to discern a pattern of when it does/doesn't work.

I am testing multiple PWA's that worked offline without issue in iOS 14.4 (like https://airhorner.com/)

I'm having the issue on both the 14.5 release (Mozilla/5.0 (iPhone; CPU iPhone OS 14_5 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1 Mobile/15E148 Safari/604.1)

and 14.6 Beta (Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15))
Comment 1 Radar WebKit Bug Importer 2021-04-27 14:56:50 PDT
<rdar://problem/77232062>
Comment 2 youenn fablet 2021-04-29 06:21:19 PDT
Created attachment 427341 [details]
Patch
Comment 3 EWS 2021-04-30 11:18:07 PDT
Committed r276845 (237196@main): <https://commits.webkit.org/237196@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 427341 [details].