Bug 224630 - [PlayStation][OpenSSL] Remove warnings.
Summary: [PlayStation][OpenSSL] Remove warnings.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Basuke Suzuki
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-04-15 16:23 PDT by Basuke Suzuki
Modified: 2021-04-24 15:08 PDT (History)
6 users (show)

See Also:


Attachments
PATCH (7.28 KB, patch)
2021-04-15 17:30 PDT, Basuke Suzuki
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
PATCH (7.28 KB, patch)
2021-04-15 18:50 PDT, Basuke Suzuki
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Basuke Suzuki 2021-04-15 16:23:17 PDT
There're two kinds of warnings in curl and openssl layer in our platform.

a) Unused param

b) '__WORDSIZE' is not defined. 
[2530/5050] Building CXX object Source/WebCore/CM...es/unified-sources/UnifiedSource-44a97133-1.cpp.oIn file included from WebCore/DerivedSources/unified-sources/UnifiedSource-44a97133-1.cpp:8:
../../Source/WebCore\crypto/algorithms/CryptoAlgorithmAES_GCM.cpp:42:5: warning: '__WORDSIZE' is not defined, evaluates to 0 [-Wundef]
#if __WORDSIZE >= 64
    ^
../../Source/WebCore\crypto/algorithms/CryptoAlgorithmAES_GCM.cpp:80:5: warning: '__WORDSIZE' is not defined, evaluates to 0 [-Wundef]
#if __WORDSIZE >= 64
    ^
../../Source/WebCore\crypto/algorithms/CryptoAlgorithmAES_GCM.cpp:123:5: warning: '__WORDSIZE' is not defined, evaluates to 0 [-Wundef]
#if __WORDSIZE >= 64
    ^
3 warnings generated.
Comment 1 Basuke Suzuki 2021-04-15 17:30:01 PDT
Created attachment 426159 [details]
PATCH
Comment 2 Stephan Szabo 2021-04-15 18:01:06 PDT
Comment on attachment 426159 [details]
PATCH

View in context: https://bugs.webkit.org/attachment.cgi?id=426159&action=review

> Source/WebCore/crypto/openssl/CryptoKeyRSAOpenSSL.cpp:36
> +RefPtr<CryptoKeyRSA> CryptoKeyRSA::create(CryptoAlgorithmIdentifier, CryptoAlgorithmIdentifier, bool hasHash, const CryptoKeyRSAComponents&, bool extractable, CryptoKeyUsageBitmap)

Is there a reason to remove just one argument's name here and then use UNUSED_PARAM for the others arguments? It seems like it'd be better to be consistent.
Comment 3 Basuke Suzuki 2021-04-15 18:50:10 PDT
Created attachment 426169 [details]
PATCH
Comment 4 Basuke Suzuki 2021-04-15 18:52:12 PDT
Comment on attachment 426159 [details]
PATCH

View in context: https://bugs.webkit.org/attachment.cgi?id=426159&action=review

>> Source/WebCore/crypto/openssl/CryptoKeyRSAOpenSSL.cpp:36
>> +RefPtr<CryptoKeyRSA> CryptoKeyRSA::create(CryptoAlgorithmIdentifier, CryptoAlgorithmIdentifier, bool hasHash, const CryptoKeyRSAComponents&, bool extractable, CryptoKeyUsageBitmap)
> 
> Is there a reason to remove just one argument's name here and then use UNUSED_PARAM for the others arguments? It seems like it'd be better to be consistent.

I follow style guideline that if the argument is described enough by type, then it should be omitted if possible. On the other hand, bool, int or such general type is not.
Comment 5 Stephan Szabo 2021-04-15 18:59:11 PDT
(In reply to Basuke Suzuki from comment #4)
> Comment on attachment 426159 [details]
> PATCH
> 
> I follow style guideline that if the argument is described enough by type,
> then it should be omitted if possible. On the other hand, bool, int or such
> general type is not.

Okay, that seems like a reasonable division. :)
Comment 6 EWS 2021-04-16 14:07:37 PDT
Committed r276167 (236654@main): <https://commits.webkit.org/236654@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 426169 [details].
Comment 7 Radar WebKit Bug Importer 2021-04-24 15:08:50 PDT
<rdar://problem/77110115>