Bug 22450 - Crash: Nightly Build fails repeatable on a web page with VLC media (imgconvert.c:2533)
Summary: Crash: Nightly Build fails repeatable on a web page with VLC media (imgconver...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://stb.st.funpic.de/solranking/vi...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-24 02:26 PST by Alexander Willner
Modified: 2008-11-24 02:57 PST (History)
1 user (show)

See Also:


Attachments
Crash log (105.61 KB, text/plain)
2008-11-24 02:30 PST, Alexander Willner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Willner 2008-11-24 02:26:34 PST
Overview Description: 

Opening certain AVI video files using VLC crashes WebKit.

Steps to Reproduce:

1) Open the page: http://stb.st.funpic.de/solranking/sol-ranking2.htm

2) Click on one of the litte "v" icons. E.g.: http://stb.st.funpic.de/solranking/vids/morak_10_333.avi
                  
Actual Results: 

The application crashed in com.netscape.vlc: img_convert + 2516 (imgconvert.c:2204). Stack Trace attached.

Expected Results: 

Show the video embedded. Video works fine in plain VLC.

Build Date & Platform: 
 * Mac OS X 10.5.5 PowerPC
 * Safari Preview (Version 4.0 (5528.1))
 * Safari Nightly (Version 4.0 (5528.1, r38698))
 
Doesn't Occur On:
 * Mac OS X 10.5.5 PowerPC
 * Firefox (Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1)
 * Also doesn't occur on other AVI files. E.g: http://www.msl.ri.cmu.edu/projects/minifactory/video/moviefly.avi works fine.

Additional Information:

Thread 13 Crashed:
0   libSystem.B.dylib             	0x92a83790 allocate_pages + 4
1   libSystem.B.dylib             	0x92a841a4 large_and_huge_malloc + 200
2   libSystem.B.dylib             	0x92a7b780 szone_malloc + 480
3   libSystem.B.dylib             	0x92a7b54c malloc_zone_malloc + 112
4   libSystem.B.dylib             	0x92a7b4ac malloc + 64
5   com.netscape.vlc              	0x07d3a0d0 img_convert + 2516 (imgconvert.c:2204)
6   com.netscape.vlc              	0x07d3a10c img_convert + 2576 (imgconvert.c:2533)
7   com.netscape.vlc              	0x07d3a10c img_convert + 2576 (imgconvert.c:2533)
...
509 com.netscape.vlc              	0x07d3a10c img_convert + 2576 (imgconvert.c:2533)
Comment 1 Mark Rowe (bdash) 2008-11-24 02:28:17 PST
Can you please attach a complete crash log?  See <http://webkit.org/quality/crashlogs.html> for details.

Based on the partial backtrace you provided, it appears that this crash is inside VLC itself which would almost certainly indicate that this is not a WebKit bug.  The full crash log will help confirm this.
Comment 2 Alexander Willner 2008-11-24 02:30:47 PST
Created attachment 25420 [details]
Crash log
Comment 3 Mark Rowe (bdash) 2008-11-24 02:34:38 PST
Based on the backtrace that definitely looks like a VLC bug.  I can't see any way that WebKit could be responsible for that.  Please report it to the VLC developers.
Comment 4 Alexander Willner 2008-11-24 02:35:48 PST
(In reply to comment #1)
> Can you please attach a complete crash log?  See
> <http://webkit.org/quality/crashlogs.html> for details.
> 
> Based on the partial backtrace you provided, it appears that this crash is
> inside VLC itself which would almost certainly indicate that this is not a
> WebKit bug.  The full crash log will help confirm this.
> 

Thank you for the quick reply. I promised to attach a crash log in the description and here it is.
Also you're right that VLC crashes. Although the files can be shown in
 * VLC (Version 0.9.6 Grishenko (PowerPC))
 * Firefox (Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1)
 * Camino (Version 1.6.5 (1.8.1.18 2008111212))

This is why I thought it could be WebKit related.
Comment 5 Mark Rowe (bdash) 2008-11-24 02:54:51 PST
It is of course possible that it is somehow WebKit's fault, but there's nothing in the crash log to suggest it.  The crash is on a secondary thread that VLC has created, and is entirely within VLC code.
Comment 6 Alexander Willner 2008-11-24 02:57:09 PST
Created a VLC bug report at http://trac.videolan.org/vlc/ticket/2314