Bug 224394 - scrollingTreeNodeDidScroll() should just trigger a rendering udpate
Summary: scrollingTreeNodeDidScroll() should just trigger a rendering udpate
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-04-09 15:05 PDT by Simon Fraser (smfr)
Modified: 2021-04-20 12:45 PDT (History)
10 users (show)

See Also:


Attachments
Patch (6.90 KB, patch)
2021-04-09 15:47 PDT, Simon Fraser (smfr)
ews-feeder: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2021-04-09 15:05:29 PDT
scrollingTreeNodeDidScroll() should just trigger a rendering udpate
Comment 1 Simon Fraser (smfr) 2021-04-09 15:47:46 PDT
Created attachment 425660 [details]
Patch
Comment 2 EWS 2021-04-09 19:11:09 PDT
Committed r275790 (236361@main): <https://commits.webkit.org/236361@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 425660 [details].
Comment 3 Radar WebKit Bug Importer 2021-04-09 19:16:05 PDT
<rdar://problem/76481198>
Comment 4 Alejandro G. Castro 2021-04-15 04:05:56 PDT
This patch broke the async scrolling for gtk and wpe, we do not have the call to synchronizeStateFromScrollingTree in Nicosia implementation. I could fix adding a willStartRenderingUpdate implementation to Nicosia that syncs but I'll take this failure as an opportunitty to review the whole synchronization because maybe we have other differences that can cause trouble in the future.
Comment 5 Alejandro G. Castro 2021-04-20 12:45:42 PDT
Created bug 224824 to solve the regression in WPE and GTK.