Bug 224340 - [Cocoa] Reduce usage of autorelease, fix mistakes noticed nearby code using autorelease
Summary: [Cocoa] Reduce usage of autorelease, fix mistakes noticed nearby code using a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Darin Adler
URL:
Keywords: InRadar
Depends on: 226670
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-08 13:52 PDT by Darin Adler
Modified: 2021-06-04 21:09 PDT (History)
4 users (show)

See Also:


Attachments
Patch (28.28 KB, patch)
2021-04-08 15:19 PDT, Darin Adler
no flags Details | Formatted Diff | Diff
Patch (28.48 KB, patch)
2021-04-08 15:50 PDT, Darin Adler
andersca: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2021-04-08 13:52:19 PDT
[Cocoa] Reduce usage of autorelease, fix mistakes noticed nearby code using autorelease
Comment 1 Darin Adler 2021-04-08 15:19:35 PDT
Created attachment 425547 [details]
Patch
Comment 2 Darin Adler 2021-04-08 15:50:25 PDT
Created attachment 425552 [details]
Patch
Comment 3 Darin Adler 2021-04-09 09:43:13 PDT
Committed r275765 (236343@main): <https://commits.webkit.org/236343@main>
Comment 4 Radar WebKit Bug Importer 2021-04-09 09:44:15 PDT
<rdar://problem/76456954>
Comment 5 Chris Dumez 2021-06-04 17:37:40 PDT
Comment on attachment 425552 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=425552&action=review

> Source/WebKit/NetworkProcess/cocoa/NetworkSessionCocoa.mm:510
> +    setIgnoreHSTS(mutableRequest.get(), false);

This should be shouldIgnoreHSTS , not false. Likely the cause of rdar://problem/78066692
Comment 6 Alex Christensen 2021-06-04 17:43:52 PDT
Fixing in https://bugs.webkit.org/show_bug.cgi?id=226670
Comment 7 Darin Adler 2021-06-04 21:09:16 PDT
Comment on attachment 425552 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=425552&action=review

>> Source/WebKit/NetworkProcess/cocoa/NetworkSessionCocoa.mm:510
>> +    setIgnoreHSTS(mutableRequest.get(), false);
> 
> This should be shouldIgnoreHSTS , not false. Likely the cause of rdar://problem/78066692

Oh, no! Thanks for spotting this.