Bug 224061 - REGRESSION (r275358): [ macOS ] 2X media/modern-media-controls layout-tests are text failing
Summary: REGRESSION (r275358): [ macOS ] 2X media/modern-media-controls layout-tests a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-04-01 11:51 PDT by Robert Jenner
Modified: 2021-04-01 15:50 PDT (History)
9 users (show)

See Also:


Attachments
Patch (7.53 KB, patch)
2021-04-01 14:20 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Jenner 2021-04-01 11:51:37 PDT
media/modern-media-controls/macos-fullscreen-media-controls/macos-fullscreen-media-controls-buttons-styles.html

Is a constant text failure macOS. 

media/modern-media-controls/macos-inline-media-controls/macos-inline-media-dropping-controls.html

Constantly fails on BigSur wk2. But is flakey in wk1 and on Catalina. 

HISTORY URL:
https://results.webkit.org/?suite=layout-tests&suite=layout-tests&test=media%2Fmodern-media-controls%2Fmacos-fullscreen-media-controls%2Fmacos-fullscreen-media-controls-buttons-styles.html&test=media%2Fmodern-media-controls%2Fmacos-inline-media-controls%2Fmacos-inline-media-dropping-controls.html

TEXT DIFF FOR "media/modern-media-controls/macos-fullscreen-media-controls/macos-fullscreen-media-controls-buttons-styles.html":

 PiPButton
 PASS getComputedStyle(button.element).top became "18px"
-PASS getComputedStyle(button.element).left is "36px"
+FAIL getComputedStyle(button.element).left should be 36px. Was 55px.
 PASS getComputedStyle(button.element).height is "16px"
 
 TracksButton
 PASS getComputedStyle(button.element).top became "18px"
-PASS getComputedStyle(button.element).left is "60px"
+FAIL getComputedStyle(button.element).left should be 60px. Was 98px.
 PASS getComputedStyle(button.element).height is "16px"
 
 FullscreenButton


TEXT DIFF FOR "media/modern-media-controls/macos-inline-media-controls/macos-inline-media-dropping-controls.html":

 PASS ready() became true
 
 TracksButton was dropped at 681.
-PiPButton was dropped at 681.
+PiPButton was dropped at 680.
 SkipForwardButton was dropped at 447.
 SkipBackButton was dropped at 418.
 MuteButton was dropped at 389.


The reason for putting these two together, is because it looks like they both started failing at r275358. I am currently investigating this at the moment.
Comment 1 Robert Jenner 2021-04-01 12:17:48 PDT
I was able to reproduce the test at BigSur Release ToT using the following test: 

run-webkit-test media/modern-media-controls/macos-fullscreen-media-controls/macos-fullscreen-media-controls-buttons-styles.html --iterations 100 -f

When I started to test, I found that it would fail on revisions even before, r275358. 

However, when I locally checkout revision r275357, the failures do not occur. So it appears, that r275358 is the cause of these failures.
Comment 2 Radar WebKit Bug Importer 2021-04-01 12:18:16 PDT
<rdar://problem/76115550>
Comment 3 Devin Rousso 2021-04-01 14:20:44 PDT
Created attachment 424948 [details]
Patch
Comment 4 EWS 2021-04-01 15:50:12 PDT
Committed r275391: <https://commits.webkit.org/r275391>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 424948 [details].