Bug 223297 - [GLIB] REGRESSION(r274273): fast/canvas/webgl/gl-teximage-imagebitmap.html is failing
Summary: [GLIB] REGRESSION(r274273): fast/canvas/webgl/gl-teximage-imagebitmap.html is...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Diego Pino
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2021-03-16 19:05 PDT by Diego Pino
Modified: 2021-03-18 18:16 PDT (History)
8 users (show)

See Also:


Attachments
Patch (4.81 KB, patch)
2021-03-17 20:33 PDT, Diego Pino
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Pino 2021-03-16 19:05:59 PDT
The test is failing since r274273:

https://results.webkit.org/?platform=GTK&platform=ios&platform=mac&platform=WPE&suite=layout-tests&test=fast%2Fcanvas%2Fwebgl%2Fgl-teximage-imagebitmap.html

--- /home/buildbot/worker/gtk-linux-64-release-tests/build/layout-test-results/fast/canvas/webgl/gl-teximage-imagebitmap-expected.txt
+++ /home/buildbot/worker/gtk-linux-64-release-tests/build/layout-test-results/fast/canvas/webgl/gl-teximage-imagebitmap-actual.txt
@@ -5,11 +5,12 @@
 PASS pixel 299, 149 should be 255, 0, 0, 255 was 255, 0, 0, 255
 PASS pixel 0, 75 should be 255, 0, 255, 255 was 255, 0, 255, 255
 PASS pixel 150, 75 should be 255, 0, 0, 255 was 255, 0, 0, 255
-PASS pixel 299, 75 should be 0, 255, 0, 255 was 0, 255, 0, 255
+FAIL pixel 299, 75 should be 0, 255, 0, 255 was 1, 255, 0, 255
 PASS pixel 0, 0 should be 255, 0, 0, 255 was 255, 0, 0, 255
 PASS pixel 150, 0 should be 255, 255, 0, 255 was 255, 255, 0, 255
 PASS pixel 299, 0 should be 255, 0, 0, 255 was 255, 0, 0, 255
 PASS successfullyParsed is true
+Some tests failed.

 TEST COMPLETE
Comment 1 Kenneth Russell 2021-03-17 17:36:01 PDT
This looks like perhaps the test's tolerance should just be increased. Feel free to propose a pull request at https://github.com/KhronosGroup/WebGL .
Comment 2 Diego Pino 2021-03-17 20:33:58 PDT
Created attachment 423557 [details]
Patch
Comment 3 Diego Pino 2021-03-17 20:39:09 PDT
(In reply to Kenneth Russell from comment #1)
> This looks like perhaps the test's tolerance should just be increased. Feel
> free to propose a pull request at https://github.com/KhronosGroup/WebGL .

It seems this test is not a test from the WebGL KhronosGroup test suite. I couldn't find this test in the repository, and neither the test has a KhronosGroup header, like other layout-tests (for instance, LayoutTests/fast/canvas/webgl/webgl-draw-buffers.html).
Comment 4 Kenneth Russell 2021-03-18 13:27:10 PDT
Correct, the fast/canvas/webgl/ tests don't exist in the official conformance repository https://github.com/KhronosGroup/WebGL , but there are similar tests under:

https://github.com/KhronosGroup/WebGL/tree/master/sdk/tests/conformance/textures
https://github.com/KhronosGroup/WebGL/tree/master/sdk/tests/conformance2/textures

and we'd certainly appreciate it if you'd check to see whether these cases are already covered, and if not, adding new tests to cover them. Thanks in advance for your help.
Comment 5 EWS 2021-03-18 18:15:27 PDT
Committed r274694: <https://commits.webkit.org/r274694>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 423557 [details].
Comment 6 Radar WebKit Bug Importer 2021-03-18 18:16:16 PDT
<rdar://problem/75600645>