Bug 22311 - Ending fullscreen mode causes window to lose focus.
Summary: Ending fullscreen mode causes window to lose focus.
Status: RESOLVED DUPLICATE of bug 22225
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 525.x (Safari 3.1)
Hardware: Macintosh Intel OS X 10.5
: P2 Minor
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-17 08:18 PST by Michael Martz
Modified: 2008-11-17 09:56 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Martz 2008-11-17 08:18:41 PST
After viewing a video at fullscreen with javascript (I haven't tested flash) I noticed the keyboard shortcut command-w will close the window instead of the currently open tab. A warning sheet has thus far prevented me from accidentally closing the whole window and losing my tabs. The window appears not to be key as the scroll bar and traffic light buttons turn grey. Clicking anywhere on the window will return the window to key status and fix the keyboard shortcut.
Comment 1 Alexey Proskuryakov 2008-11-17 08:46:12 PST
Could you please provide steps to reproduce this issue, such as an URL, or a test case?
Comment 2 Michael Martz 2008-11-17 08:58:55 PST
Steps to Reproduce:
1. Go to http://www.hulu.com/watch/34770/fringe-the-same-old-story#x-0,vepisode,1
2. Click the fullscreen button.
3. Press esc or click the button to leave fullscreen.

Now the window is no longer key. A quick look at the file menu will demonstrate the incorrect keyboard shortcuts.
Comment 3 Alexey Proskuryakov 2008-11-17 09:56:13 PST
OK. Hulu refuses to open, because it doesn't like where I live, but I'm pretty sure that it actually uses Flash for playback, so this is a duplicate of bug 22225.

*** This bug has been marked as a duplicate of 22225 ***