Bug 22276 - Reproducible crash in Web Inspector when clicking on error
Summary: Reproducible crash in Web Inspector when clicking on error
Status: RESOLVED DUPLICATE of bug 22398
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://db.yeastgenome.org/cgi-bin/loc...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-14 22:22 PST by Gavin Sherlock
Modified: 2008-11-26 09:15 PST (History)
0 users

See Also:


Attachments
Crash log (26.26 KB, text/plain)
2008-11-14 22:24 PST, Gavin Sherlock
no flags Details
webarchive of page (185.70 KB, application/x-webarchive)
2008-11-14 22:25 PST, Gavin Sherlock
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Sherlock 2008-11-14 22:22:37 PST
Steps to reproduce:

1.  Go to http://db.yeastgenome.org/cgi-bin/locus.pl?locus=CLB2
2.  Open Web Inspector (docked)
3.  Reload page (errors don't show up unless you reload - probably needs another bug)
4.  After reloading, there should be an indication of 33 errors in the bottom right hand corner - click on that.
5.  Click on the top error (line 413) and wait.

Eventually, it will crash.  Tested with r38386 on 10.5.5.
Comment 1 Gavin Sherlock 2008-11-14 22:24:05 PST
Created attachment 25180 [details]
Crash log

Top of crashed thread is:

1   com.apple.WebCore             	0x0140b0c2 WebCore::AnimationTimerCallback::timerFired(WebCore::Timer<WebCore::AnimationTimerBase>*) + 34
2   com.apple.WebCore             	0x0140deeb WebCore::Timer<WebCore::AnimationTimerBase>::fired() + 43
3   com.apple.WebCore             	0x012dd8d5 WebCore::TimerBase::fireTimers(double, WTF::Vector<WebCore::TimerBase*, 0ul> const&) + 133
4   com.apple.WebCore             	0x012ddba2 WebCore::TimerBase::sharedTimerFired() + 162
Comment 2 Gavin Sherlock 2008-11-14 22:25:04 PST
Created attachment 25181 [details]
webarchive of page

Page might change, so here is a webarchive
Comment 3 Gavin Sherlock 2008-11-14 22:26:32 PST
Unfortunately, it's not reproducible with the archive, as the errors don't show up for some reason.  That should probably be another bug.
Comment 4 Timothy Hatcher 2008-11-26 09:15:04 PST

*** This bug has been marked as a duplicate of 22398 ***