Bug 22224 - window.location.replace seems to save the session history
Summary: window.location.replace seems to save the session history
Status: RESOLVED DUPLICATE of bug 42861
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://desktop.nostdal.org/~lnostdal/...
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2008-11-12 18:19 PST by Anantha Keesara
Modified: 2011-06-30 18:28 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anantha Keesara 2008-11-12 18:19:45 PST
chromium bug:http://code.google.com/p/chromium/issues/detail?id=1919

Code snippet:
<html>
  <head>
  </head>

  <body onload="var before = history.length;
                window.location.replace('#blah');
                var after = history.length;
                if(before != after)
                  alert(before + ' != ' + after);
                ">
    <a href="test.html">again..</a>

    <p/>
    (also, it seems i need to click twice on the link for it to trigger a
reload .. which isn't the case in FF)
  </body>
</html>


..works as expected (does not add history entry) under FF, Opera and IE


Nightly tested: r38293
Comment 1 sunsean 2009-09-17 11:42:33 PDT
This bug often causes infinite loops (when pressing the back button) on pages that attempt to set a default hash if there is none.

if(!location.hash) location.replace('#home');
Comment 2 Mihai Parparita 2011-06-30 18:28:59 PDT

*** This bug has been marked as a duplicate of bug 42861 ***