Bug 22223 - REGRESSION(r38245): "View Source" crashes the browser
Summary: REGRESSION(r38245): "View Source" crashes the browser
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.4
: P2 Major
Assignee: Darin Adler
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2008-11-12 16:57 PST by Thomas Sutton
Modified: 2008-11-12 18:05 PST (History)
1 user (show)

See Also:


Attachments
Report of the view source crash (23.54 KB, text/plain)
2008-11-12 16:58 PST, Thomas Sutton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Sutton 2008-11-12 16:57:24 PST
The latest nightly WebKit build downloaded as WebKit-SVN-r38297.dmg crashes whenever I use the View Source function, whether by menu or shortcut. This happens on multiple sites (including twitter.com and gardnermuseum.org).

Steps to reproduce on my PPC iMac with 10.4.11:

1) Open WebKit.app
2) Browse to a web page (it appears that any will do)
3) View Source through the menu bar or alt-cmd-u.
4) The browser crashes.
Comment 1 Thomas Sutton 2008-11-12 16:58:18 PST
Created attachment 25108 [details]
Report of the view source crash
Comment 2 Mark Rowe (bdash) 2008-11-12 17:48:47 PST
<rdar://problem/6366864>
Comment 3 Darin Adler 2008-11-12 18:01:39 PST
I can't reproduce this but it's clear it's trivial to fix. Just need to null-check _private in viewDidMoveToWindow.
Comment 4 Darin Adler 2008-11-12 18:05:19 PST
http://trac.webkit.org/changeset/38355