Bug 221895 - [selectors] :focus-visible parsing and experimental flag
Summary: [selectors] :focus-visible parsing and experimental flag
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Manuel Rego Casasnovas
URL:
Keywords: InRadar, WebExposed
Depends on:
Blocks: 185859
  Show dependency treegraph
 
Reported: 2021-02-15 03:15 PST by Manuel Rego Casasnovas
Modified: 2021-02-16 21:55 PST (History)
11 users (show)

See Also:


Attachments
Patch (13.67 KB, patch)
2021-02-15 03:16 PST, Manuel Rego Casasnovas
no flags Details | Formatted Diff | Diff
Patch (42.90 KB, patch)
2021-02-15 04:40 PST, Manuel Rego Casasnovas
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Patch (45.58 KB, patch)
2021-02-15 09:09 PST, Manuel Rego Casasnovas
no flags Details | Formatted Diff | Diff
Patch (45.53 KB, patch)
2021-02-16 11:18 PST, Manuel Rego Casasnovas
no flags Details | Formatted Diff | Diff
Patch (45.53 KB, patch)
2021-02-16 11:29 PST, Manuel Rego Casasnovas
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Rego Casasnovas 2021-02-15 03:15:20 PST
[selectors] :focus-visible parsing and experimental flag
Comment 1 Manuel Rego Casasnovas 2021-02-15 03:16:06 PST
Created attachment 420299 [details]
Patch
Comment 2 Manuel Rego Casasnovas 2021-02-15 04:40:33 PST
Created attachment 420307 [details]
Patch
Comment 3 Manuel Rego Casasnovas 2021-02-15 09:09:21 PST
Created attachment 420321 [details]
Patch
Comment 4 Manuel Rego Casasnovas 2021-02-15 12:57:26 PST
EWSs are green or have unrelated failures, I believe this is ready for review. PTAL.
Comment 5 Darin Adler 2021-02-16 10:21:05 PST
Comment on attachment 420321 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=420321&action=review

> Source/WebCore/css/SelectorCheckerTestFunctions.h:480
> +    if (InspectorInstrumentation::forcePseudoState(element, CSSSelector::PseudoClassFocusVisible))
> +        return true;
> +
> +    return false;

Should just be a return statement, no need for if true else false.

> LayoutTests/imported/w3c/ChangeLog:8
> +        Update expectations as now :focus-visible is a valid selector.

Is this because the feature is on for regression tests? Or do these changes happen with the feature still off?

If the latter, I am worried that even these small changes could cause compatibility problems.
Comment 6 Manuel Rego Casasnovas 2021-02-16 11:15:07 PST
Comment on attachment 420321 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=420321&action=review

Thanks for the review.

>> Source/WebCore/css/SelectorCheckerTestFunctions.h:480
>> +    return false;
> 
> Should just be a return statement, no need for if true else false.

True, changed that.

>> LayoutTests/imported/w3c/ChangeLog:8
>> +        Update expectations as now :focus-visible is a valid selector.
> 
> Is this because the feature is on for regression tests? Or do these changes happen with the feature still off?
> 
> If the latter, I am worried that even these small changes could cause compatibility problems.

AFAIK the experimental feature flags are enabled by default for tests, but not when you run minibrowser for example.
Comment 7 Manuel Rego Casasnovas 2021-02-16 11:18:02 PST
Created attachment 420504 [details]
Patch
Comment 8 Manuel Rego Casasnovas 2021-02-16 11:29:54 PST
Created attachment 420510 [details]
Patch
Comment 9 EWS 2021-02-16 21:54:20 PST
Committed r272983: <https://commits.webkit.org/r272983>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 420510 [details].
Comment 10 Radar WebKit Bug Importer 2021-02-16 21:55:13 PST
<rdar://problem/74421155>