Bug 22157 - Flash animations draw over other tabs
Summary: Flash animations draw over other tabs
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.novinite.com
Keywords: InRadar, Regression
: 22181 22198 22288 22354 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-10 08:40 PST by Sveto
Modified: 2008-11-21 11:57 PST (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sveto 2008-11-10 08:40:10 PST
There is a memory leek created in versions of Webkit greater than r38068. Flash content from one tab draws over the content from other tabs where different pages are loaded. The only way to clear the flash animation is to close the tab that contains it.
For example load www.google.com and than on another tab www.novinite.com. Once that las page load and you go to the google tab you will see the flash animations from www.novinite.com
Comment 1 Mark Rowe (bdash) 2008-11-11 13:01:27 PST
*** Bug 22181 has been marked as a duplicate of this bug. ***
Comment 2 Matt Lilek 2008-11-11 20:59:25 PST
*** Bug 22198 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Kempgen 2008-11-12 12:04:17 PST
working in nightly r38068, broken in r38202.

osx 10.5.5 ppc, Flash 9.0 r124
Comment 4 Mark Rowe (bdash) 2008-11-15 19:12:37 PST
*** Bug 22288 has been marked as a duplicate of this bug. ***
Comment 5 Mark Rowe (bdash) 2008-11-15 19:12:57 PST
<rdar://problem/6375422>
Comment 6 Anders Carlsson 2008-11-19 18:35:54 PST
This might have been fixed in http://trac.webkit.org/changeset/38611

If someone wants to build ToT and verify that would be great :)
Comment 7 Mark Rowe (bdash) 2008-11-19 18:57:06 PST
*** Bug 22354 has been marked as a duplicate of this bug. ***
Comment 8 Alexander Kempgen 2008-11-21 11:54:06 PST
fixed in nightly r38654