Finish introduction of RenderLayerScrollableArea: remove remaining glue code from RenderLayer
Created attachment 418124 [details] Patch, v1
Created attachment 418174 [details] Patch, v2
Comment on attachment 418174 [details] Patch, v2 View in context: https://bugs.webkit.org/attachment.cgi?id=418174&action=review > Source/WebCore/page/EventHandler.cpp:1499 > + return layer->renderer().shouldPlaceBlockDirectionScrollbarOnLeft() ? southWestResizeCursor() : southEastResizeCursor(); Isn't layer->renderer() just renderer? > Source/WebCore/page/FrameView.cpp:2601 > + if (auto* scrollableLayer = renderView->layer()->scrollableArea()) > + scrollableLayer->updateLayerPositionsAfterDocumentScroll(); Is it a scrollableLayer or scrollableArea? Pick one! I think all of these would read better as layerScrollableArea or just scrollableArea
(In reply to Simon Fraser (smfr) from comment #3) > Isn't layer->renderer() just renderer? Fixed. > > Source/WebCore/page/FrameView.cpp:2601 > > + if (auto* scrollableLayer = renderView->layer()->scrollableArea()) > > + scrollableLayer->updateLayerPositionsAfterDocumentScroll(); > > Is it a scrollableLayer or scrollableArea? Pick one! I think all of these > would read better as layerScrollableArea or just scrollableArea Okay, I propose to prepare a follow-up patch that consistently uses the 'scrollableArea' naming scheme instead of 'scrollableLayer' or variations.
As discused on Slack, I'll prepare another polished version of the patch including the variable renames (s/scrollableLayer/scrollableArea/ in many places).
Created attachment 418195 [details] Patch, v3
Committed r271814: <https://trac.webkit.org/changeset/r271814>
<rdar://problem/73588759>