Bug 22055 - Input search cross doesn't re-appear after emptying and typing again
Summary: Input search cross doesn't re-appear after emptying and typing again
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 525.x (Safari 3.1)
Hardware: Macintosh OS X 10.5
: P2 Minor
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-03 14:23 PST by Yves Van Goethem
Modified: 2009-05-05 09:11 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yves Van Goethem 2008-11-03 14:23:54 PST
Description :
Search field doesn't react as other native Mac search fields (e. g.: Finder & Safari)

Steps to reproduce :
1. Type some stuff in a search field (input type="search") ;
2. Click on the cross to remove the content ;
3. You still get the focus, re-type something ;
4. bug : The cross doesn't appear until you lost the focus of the search field.
Comment 1 Anthony Ricaud 2008-11-03 14:31:00 PST
Confirmed with r38068
Comment 2 Anthony Ricaud 2009-04-02 09:29:43 PDT
I can't reproduce this anymore with r42162 on Mac.
Comment 3 Yves Van Goethem 2009-05-05 09:11:58 PDT
Fixed !
Works fine in WebKit r43163 on Mac.