Bug 22036 - Setting contentEditable=false inside a document with designMode='on' fails
: Setting contentEditable=false inside a document with designMode='on' fails
Status: RESOLVED DUPLICATE of bug 53031
Product: WebKit
Classification: Unclassified
Component: HTML Editing
: 528+ (Nightly build)
: PC Windows XP
: P2 Normal
Assigned To: Nobody
: HasReduction
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 03:49 PST by Alfonso Martínez de Lizarrondo
Modified: 2011-05-02 13:36 PDT (History)
8 users (show)

See Also:


Attachments
testcase (499 bytes, text/html)
2008-11-02 03:50 PST, Alfonso Martínez de Lizarrondo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alfonso Martínez de Lizarrondo 2008-11-02 03:49:10 PST
According to http://www.w3.org/html/wg/html5/#contenteditable if an element has
contentEditable=false then it should not be editable, even if the rest of the
document has designMode='on'.

This testcase proves that Firefox, Safari and Opera fail to disable the editing
in such situation.

Filed in Mozilla as https://bugzilla.mozilla.org/show_bug.cgi?id=462735
Comment 1 Alfonso Martínez de Lizarrondo 2008-11-02 03:50:22 PST
Created attachment 24842 [details]
testcase

The second paragraph shouldn't be editable
Comment 2 Benjamin Poulain 2011-04-24 09:46:06 PDT
*** Bug 58966 has been marked as a duplicate of this bug. ***
Comment 3 Ryosuke Niwa 2011-05-02 13:35:10 PDT
I think this bug should have been fixed since http://trac.webkit.org/changeset/85267.
Comment 4 Ryosuke Niwa 2011-05-02 13:36:48 PDT
Confirmed that the bug no longer reproduces on the latest nightly build.

*** This bug has been marked as a duplicate of bug 53031 ***