WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
22035
Remove the '_' suffix on constructor parameter names for structs
https://bugs.webkit.org/show_bug.cgi?id=22035
Summary
Remove the '_' suffix on constructor parameter names for structs
Cameron Zwarich (cpst)
Reported
2008-11-02 03:10:49 PST
In the past, we had a lot of structs whose constructors took parameters which were of the form "field_". Recently, Darin has been changing a number of these use the same name as the field, which is perfectly allowable by C++ scoping rules. I think it looks better (and doesn't cause confusion with the fairly common style of using '_' as a suffix for member variables). I have a patch to do the rest of the in JavaScriptCore.
Attachments
Proposed patch
(4.36 KB, patch)
2008-11-02 03:12 PST
,
Cameron Zwarich (cpst)
oliver
: review+
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Cameron Zwarich (cpst)
Comment 1
2008-11-02 03:12:37 PST
Created
attachment 24841
[details]
Proposed patch
Oliver Hunt
Comment 2
2008-11-02 03:25:29 PST
Comment on
attachment 24841
[details]
Proposed patch r=me
Cameron Zwarich (cpst)
Comment 3
2008-11-02 03:30:26 PST
Landed in
r38066
.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug