Bug 220187 - REGRESSION (2020-10-23): webanimations/accelerated-animation-with-easing.html is flaky on Mac Debug
Summary: REGRESSION (2020-10-23): webanimations/accelerated-animation-with-easing.html...
Status: RESOLVED DUPLICATE of bug 224066
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-12-28 12:59 PST by Alexey Proskuryakov
Modified: 2021-04-09 08:54 PDT (History)
3 users (show)

See Also:


Attachments
Patch (3.06 KB, patch)
2021-01-06 08:04 PST, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (3.12 KB, patch)
2021-01-06 08:15 PST, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2020-12-28 12:59:47 PST
webanimations/accelerated-animation-with-easing.html used to pass reliably on Mac (not on Linux), but it's become flaky on Debug starting 2020-10-23. 

First failure observed on r268941. The closest animations related change before that was http://trac.webkit.org/r268932.

History: https://results.webkit.org/?suite=layout-tests&test=webanimations%2Faccelerated-animation-with-easing.html

The diff is an image, there is a thick red line on actual image.
Comment 1 Alexey Proskuryakov 2020-12-28 13:04:07 PST
Added a flaky expectation in http://trac.webkit.org/r271104
Comment 2 Radar WebKit Bug Importer 2021-01-04 13:00:26 PST
<rdar://problem/72796329>
Comment 3 Antoine Quint 2021-01-06 08:04:44 PST
Created attachment 417086 [details]
Patch
Comment 4 Antoine Quint 2021-01-06 08:15:46 PST
Created attachment 417087 [details]
Patch
Comment 5 EWS 2021-01-06 12:03:24 PST
Committed r271208: <https://trac.webkit.org/changeset/271208>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 417087 [details].
Comment 6 Antoine Quint 2021-01-07 00:05:04 PST
Does not seem to have helped much on the bots :(
Comment 7 Antoine Quint 2021-04-08 05:36:54 PDT
This used to reproduce the issue reliably:

rwt --debug --iterations=10000 --force --exit-after-n-failures=1 --no-build webanimations/accelerated-animation-with-easing.html

… but doesn't anymore.
Comment 8 Alexey Proskuryakov 2021-04-08 10:19:22 PDT
On the bots, I see flakiness in all configurations, but mostly on release, ASan and GuardMalloc - failures in debug are rare.
Comment 9 Antoine Quint 2021-04-09 08:54:59 PDT
I'll be addressing this in bug 224066.

*** This bug has been marked as a duplicate of bug 224066 ***