Bug 21955 - Shift + PageDown doesn't select text in Gmail compose window
Summary: Shift + PageDown doesn't select text in Gmail compose window
Status: RESOLVED DUPLICATE of bug 18819
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 525.x (Safari 3.1)
Hardware: PC Windows Vista
: P2 Normal
Assignee: Nobody
URL: http://gmail.com
Keywords: GoogleBug
Depends on:
Blocks: 29977
  Show dependency treegraph
 
Reported: 2008-10-29 13:47 PDT by Jon@Chromium
Modified: 2010-02-28 21:44 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon@Chromium 2008-10-29 13:47:43 PDT
Originated from the Chromium bug tracker, see http://code.google.com/p/chromium/issues/detail?id=3159

If I go to a message and select New Windows from the options on the top right I get a new window and select with shift-pageup/pagedown no longer works.

Add OK or FAIL after other browsers where you have tested this issue:
Safari 3:
    Firefox 3: OK
         IE 7: OK

What steps will reproduce the problem?
1.  Open GMail
2.  Select a message
3.  Click the New Window link to the right of the message display
4.  Click Reply
5.  Copy in a large amount of text
6.  Use Shift+Ctrl+PgDown to attempt to select all of the text

When composing a Gmail message (in Chrome/Windows), Shift + Page-Down 
doesn't select text (neither does Shift + Page-Up). Shift + DownArrow or 
UpArrow does select text. IE and Firefox allow the Shift + PageDown method 
to select text.

What is the expected result?
Text should be selected.

What happens instead?
No text is selected.
Comment 1 Karen 2009-09-25 11:11:55 PDT
this bug only occurs for rich-text content. if the content is plain text, the content is correctly selected.
Comment 2 Alexey Proskuryakov 2009-09-25 16:19:06 PDT
FWIW, I cannot reproduce this in Mac Safari 4.0.3.

> 6.  Use Shift+Ctrl+PgDown to attempt to select all of the text

The rest of bug description doesn't mention Ctrl.
Comment 3 Karen 2009-09-28 14:08:17 PDT
AFAIK it's a PC-only bug. I can reproduce it on PC Safari.
Comment 4 Tony Chang 2010-02-28 21:44:06 PST
This is the same cause as 18819.

*** This bug has been marked as a duplicate of bug 18819 ***