Bug 219531 - <use> fails to target <path> inserted later
Summary: <use> fails to target <path> inserted later
Status: RESOLVED DUPLICATE of bug 216363
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-12-03 22:50 PST by Kaiido
Modified: 2023-05-30 11:10 PDT (History)
10 users (show)

See Also:


Attachments
test case (648 bytes, text/html)
2020-12-03 22:50 PST, Kaiido
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kaiido 2020-12-03 22:50:16 PST
Created attachment 415389 [details]
test case

https://jsfiddle.net/g36aokvt/

When a <use> element targets a <path> element that will be appended in the DOM after the <use>, the <use> element fails to update and to clone the target correctly.  
This works fine in every browsers and in WebKit too when the target is a <rect> or a <circle>.

I guess this is a recent regression, but I was unable to run bisect-builds correctly to be sure.
Comment 1 Smoley 2020-12-07 13:42:48 PST
Thanks for filing, I can reproduce this on Safari 13.1.3 as well as STP 116.
Comment 2 Radar WebKit Bug Importer 2020-12-07 13:43:01 PST
<rdar://problem/72062144>
Comment 3 Ahmad Saleem 2022-08-12 00:26:45 PDT
I am able to reproduce this bug in Safari 15.6 and Safari Technical Preview 151 where the test case does not show "red" square like other browsers (Chrome Canary 106 and Firefox Nightly 105) after some time. Just wanted to share updated test results. Thanks!
Comment 4 Ahmad Saleem 2023-05-30 10:46:17 PDT
It seems to work in WebKit ToT (264678@main) and I think it is fixed now.

Will wait for someone else also to confirm since I do have some SVG patches in my local builds with above ToT.
Comment 5 Said Abou-Hallawa 2023-05-30 11:10:33 PDT
This was fixed by the fix of bug 216363 (264085@main).

*** This bug has been marked as a duplicate of bug 216363 ***