Bug 218902 - Add support for discrete animations of many CSS properties
Summary: Add support for discrete animations of many CSS properties
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar, WebExposed
: 219564 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-13 07:19 PST by Antoine Quint
Modified: 2020-12-07 00:05 PST (History)
13 users (show)

See Also:


Attachments
Patch (110.23 KB, patch)
2020-11-13 08:10 PST, Antoine Quint
koivisto: review+
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Patch (121.99 KB, patch)
2020-11-13 12:19 PST, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Quint 2020-11-13 07:19:24 PST
Add support for discrete animations of many CSS properties
Comment 1 Antoine Quint 2020-11-13 07:34:06 PST
Namely: -webkit-backface-visibility, -webkit-box-decoration-break, -webkit-hyphens, -webkit-initial-letter, -webkit-print-color-adjust, -webkit-ruby-position, -webkit-text-emphasis-color, -webkit-text-emphasis-position, border-bottom-style, border-collapse, border-left-style, border-right-style, border-top-style, box-sizing, caption-side, clear, column-fill, column-rule-style, column-rule-style, cursor, empty-cells, flex-direction, flex-wrap, float, grid-auto-columns, grid-auto-flow, grid-auto-rows, grid-column-end, grid-column-start, grid-row-end, grid-row-start, image-orientation, isolation, justify-content, justify-items, justify-self, list-style-position, list-style-type, mix-blend-mode, object-fit, outline-style, overflow-wrap, overflow-x, overflow-y, page-break-after, page-break-before, page-break-inside, paint-order, pointer-events, position, resize, scroll-behavior, table-layout, text-align, text-decoration-color, text-decoration-line, text-decoration-style, text-overflow, text-transform, touch-action, transform-box, transform-style, white-space, word-break.
Comment 2 Antoine Quint 2020-11-13 08:10:14 PST
Created attachment 414044 [details]
Patch
Comment 3 Antti Koivisto 2020-11-13 08:15:06 PST
Comment on attachment 414044 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=414044&action=review

> Source/WebCore/animation/CSSPropertyAnimation.cpp:1917
>          new DiscretePropertyWrapper<const StyleContentAlignmentData&>(CSSPropertyAlignContent, &RenderStyle::alignContent, &RenderStyle::setAlignContent),
>          new DiscretePropertyWrapper<const StyleSelfAlignmentData&>(CSSPropertyAlignItems, &RenderStyle::alignItems, &RenderStyle::setAlignItems),
>          new DiscretePropertyWrapper<const StyleSelfAlignmentData&>(CSSPropertyAlignSelf, &RenderStyle::alignSelf, &RenderStyle::setAlignSelf),
> +        new DiscretePropertyWrapper<BackfaceVisibility>(CSSPropertyWebkitBackfaceVisibility, &RenderStyle::backfaceVisibility, &RenderStyle::setBackfaceVisibility),

Maybe this stuff should be generated from CSSProperties.json?
Comment 4 Antoine Quint 2020-11-13 12:18:48 PST
Actually, scroll-behavior will be for another bug.
Comment 5 Antoine Quint 2020-11-13 12:19:28 PST
Created attachment 414077 [details]
Patch
Comment 6 Antoine Quint 2020-11-14 00:53:18 PST
Committed r269812: <https://trac.webkit.org/changeset/269812>
Comment 7 Radar WebKit Bug Importer 2020-11-14 00:54:18 PST
<rdar://problem/71398181>
Comment 8 Antoine Quint 2020-12-07 00:05:27 PST
*** Bug 219564 has been marked as a duplicate of this bug. ***