Bug 218785 - [TextureMapper] blur backdrop-filter makes its box-shadow blurry
Summary: [TextureMapper] blur backdrop-filter makes its box-shadow blurry
Status: RESOLVED DUPLICATE of bug 215445
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Fujii Hironori
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-10 20:33 PST by Fujii Hironori
Modified: 2020-11-11 12:00 PST (History)
9 users (show)

See Also:


Attachments
test case (1.44 KB, text/html)
2020-11-10 20:33 PST, Fujii Hironori
no flags Details
WIP patch (1.28 KB, patch)
2020-11-10 21:40 PST, Fujii Hironori
no flags Details | Formatted Diff | Diff
WIP patch (1.03 KB, patch)
2020-11-10 21:40 PST, Fujii Hironori
no flags Details | Formatted Diff | Diff
[Screenshot] WinCairo port (438.15 KB, image/png)
2020-11-10 21:43 PST, Fujii Hironori
no flags Details
Patch (5.65 KB, patch)
2020-11-10 22:43 PST, Fujii Hironori
no flags Details | Formatted Diff | Diff
Patch (5.73 KB, patch)
2020-11-10 22:57 PST, Fujii Hironori
ews-feeder: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fujii Hironori 2020-11-10 20:33:54 PST
Created attachment 413765 [details]
test case

[TextureMapper] blur backdrop-filter makes box-shadow blurry
Comment 1 Fujii Hironori 2020-11-10 21:40:12 PST
Created attachment 413776 [details]
WIP patch
Comment 2 Fujii Hironori 2020-11-10 21:40:59 PST
Created attachment 413777 [details]
WIP patch
Comment 3 Fujii Hironori 2020-11-10 21:43:31 PST
Created attachment 413778 [details]
[Screenshot] WinCairo port
Comment 4 Fujii Hironori 2020-11-10 22:43:34 PST
Created attachment 413784 [details]
Patch
Comment 5 Fujii Hironori 2020-11-10 22:57:42 PST
Created attachment 413785 [details]
Patch
Comment 6 Miguel Gomez 2020-11-11 08:34:58 PST
I did some testing with Carlos' patch to bug 215445. As the patch uses backdropFiltersRect as the clip rect when painting the backdrop layer, this bug gets fixed as well. Great.

I'm still working on bug 215445, as there are some details missing in the patch, and some tests that aren't passing. I'll send a new patch for it and close this when the other bug gets fixed.

Thanks for the patch anyway Fujii!
Comment 7 Fujii Hironori 2020-11-11 12:00:15 PST
Comment on attachment 413785 [details]
Patch

Oops, I missed the KaL's patch. Thank you.
Comment 8 Fujii Hironori 2020-11-11 12:00:26 PST

*** This bug has been marked as a duplicate of bug 215445 ***