Bug 218580 - [GStreamer] fast/mediastream/captureStream/canvas2d.html is flaky timing out since GStreamer 1.18 update
Summary: [GStreamer] fast/mediastream/captureStream/canvas2d.html is flaky timing out ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Philippe Normand
URL:
Keywords: InRadar
: 217829 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-04 11:53 PST by Lauro Moura
Modified: 2021-02-25 19:02 PST (History)
16 users (show)

See Also:


Attachments
Tentative example (1.10 KB, text/html)
2020-11-04 11:55 PST, Lauro Moura
no flags Details
Patch (5.96 KB, patch)
2021-02-22 08:26 PST, Philippe Normand
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lauro Moura 2020-11-04 11:53:57 PST
fast/mediastream/captureStream/canvas2d.html

Marked as flaky Pass/Fail in root expectations, it's timing out in GLib platforms, especially in Release/Wayland platforms (WPE-Release and GTK-Wayland-Release bots).

When current spell of flaky timeouts started:

WPE-Release: r267140
GTK-Wayland: r267141
GTK-Debug: r267156
GTK-Release: r267241
WPE-Debug: r268715

Revisions r267138 through r267140 were related to the GStreamer 1.18 update in the new SDK version.

At least in WPE-Release, it seems to be getting stuck in the `canvas2.getContext("2d").drawImage(video, 0 ,0);` call.

Link to results history: https://results.webkit.org/?suite=layout-tests&test=fast%2Fmediastream%2FcaptureStream%2Fcanvas2d.html
Comment 1 Lauro Moura 2020-11-04 11:55:39 PST
Created attachment 413192 [details]
Tentative example

This is a sample html test case likely related to the root issue, with the canvas1 -> video -> canvas2 pipeline drawing the canvas.

Works on firefox, but does not draw canvas2 in GTK/WPE ToT (although it does not get stuck like in the test).
Comment 2 Philippe Normand 2021-02-22 00:49:41 PST
Looks like we emit the play event before the first video frame reached the sink, that's why the canvas sourcing from the video element is empty in that test-case.
Comment 3 Philippe Normand 2021-02-22 08:26:54 PST
Created attachment 421194 [details]
Patch
Comment 4 Philippe Normand 2021-02-22 08:28:09 PST
*** Bug 217829 has been marked as a duplicate of this bug. ***
Comment 5 EWS 2021-02-23 08:58:21 PST
Committed r273309: <https://commits.webkit.org/r273309>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 421194 [details].
Comment 6 Radar WebKit Bug Importer 2021-02-23 08:59:14 PST
<rdar://problem/74644074>