Bug 218111 - [GTK] REGRESSION(r268898): compositing/clipping/border-radius-async-overflow-stacking.html fails
Summary: [GTK] REGRESSION(r268898): compositing/clipping/border-radius-async-overflow-...
Status: RESOLVED DUPLICATE of bug 242097
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Fujii Hironori
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-22 20:16 PDT by Carlos Alberto Lopez Perez
Modified: 2022-07-02 22:46 PDT (History)
11 users (show)

See Also:


Attachments
WIP patch (879 bytes, patch)
2022-06-22 17:44 PDT, Fujii Hironori
no flags Details | Formatted Diff | Diff
WIP patch (2.76 KB, patch)
2022-06-22 18:02 PDT, Fujii Hironori
ews-feeder: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2020-10-22 20:16:50 PDT
After r268898 the ref-test compositing/clipping/border-radius-async-overflow-stacking.html fails on GTK.

The failure is different depending on the display server so perhaps it has something to do with AC mode.

* Failure for xvfb-x11/softgl    -> https://build.webkit.org/results/GTK-Linux-64-bit-Release-Tests/r268900%20(16593)/compositing/clipping/border-radius-async-overflow-stacking-diffs.html
* Failure for wayland/intel-mesa -> https://build.webkit.org/results/GTK-Linux-64-bit-Release-Wayland-Tests/r268898%20(14631)/compositing/clipping/border-radius-async-overflow-non-stacking-diffs.html
Comment 1 Simon Fraser (smfr) 2020-10-23 08:06:07 PDT
Looks like I messed up the position of m_childClippingMaskLayer?
Comment 2 Fujii Hironori 2022-06-22 17:44:30 PDT
Created attachment 460436 [details]
WIP patch
Comment 3 Fujii Hironori 2022-06-22 18:02:19 PDT
Created attachment 460437 [details]
WIP patch
Comment 4 Fujii Hironori 2022-06-29 14:14:38 PDT
I'm going to fix this in bug#242097.
Comment 5 Fujii Hironori 2022-07-02 22:46:08 PDT
Fixed by 252014@main.

*** This bug has been marked as a duplicate of bug 242097 ***