Bug 217862 - Web Inspector: REGRESSION(r266074): line-based JavaScript breakpoints don't hit after reload
Summary: Web Inspector: REGRESSION(r266074): line-based JavaScript breakpoints don't h...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
: 216807 (view as bug list)
Depends on: 215362
Blocks:
  Show dependency treegraph
 
Reported: 2020-10-16 18:38 PDT by Devin Rousso
Modified: 2020-10-19 17:41 PDT (History)
11 users (show)

See Also:


Attachments
Patch (6.69 KB, patch)
2020-10-16 20:11 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2020-10-16 18:38:15 PDT
# STEPS TO REPRODUCE
1. inspect <https://webkit.org>
2. set a breakpoint inside the `DOMContentLoaded` event listener callback in `global.js`
3. reload the page

# EXPECTED
pause

# ACTUAL
no-pause, and the breakpoint shows as unresolved
Comment 1 Devin Rousso 2020-10-16 20:11:16 PDT
Created attachment 411646 [details]
Patch
Comment 2 EWS 2020-10-16 21:07:27 PDT
Committed r268629: <https://trac.webkit.org/changeset/268629>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 411646 [details].
Comment 3 Radar WebKit Bug Importer 2020-10-16 21:08:18 PDT
<rdar://problem/70402083>
Comment 4 Ryan Haddad 2020-10-19 13:34:39 PDT
inspector/debugger/breakpoint-resolve-when-script-added.html, added with this change, is frequently timing out on macOS debug bots.

https://results.webkit.org/?suite=layout-tests&test=inspector%2Fdebugger%2Fbreakpoint-resolve-when-script-added.html
Comment 5 Ryan Haddad 2020-10-19 13:42:47 PDT
(In reply to Ryan Haddad from comment #4)
> inspector/debugger/breakpoint-resolve-when-script-added.html, added with
> this change, is frequently timing out on macOS debug bots.
> 
> https://results.webkit.org/?suite=layout-
> tests&test=inspector%2Fdebugger%2Fbreakpoint-resolve-when-script-added.html
Marked the test as slow in https://trac.webkit.org/changeset/268684/webkit
Comment 6 Brian Burg 2020-10-19 15:12:20 PDT
*** Bug 216807 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Haddad 2020-10-19 17:01:49 PDT
(In reply to Ryan Haddad from comment #4)
> inspector/debugger/breakpoint-resolve-when-script-added.html, added with
> this change, is frequently timing out on macOS debug bots.
> 
> https://results.webkit.org/?suite=layout-
> tests&test=inspector%2Fdebugger%2Fbreakpoint-resolve-when-script-added.html
My statement was incorrect, this is also affecting release bots.

Devin, can you investigate this urgently or should we revert for now?
Comment 8 Ryan Haddad 2020-10-19 17:41:46 PDT
(In reply to Ryan Haddad from comment #7)
> (In reply to Ryan Haddad from comment #4)
> > inspector/debugger/breakpoint-resolve-when-script-added.html, added with
> > this change, is frequently timing out on macOS debug bots.
> > 
> > https://results.webkit.org/?suite=layout-
> > tests&test=inspector%2Fdebugger%2Fbreakpoint-resolve-when-script-added.html
> My statement was incorrect, this is also affecting release bots.
> 
> Devin, can you investigate this urgently or should we revert for now?
Tracking with https://bugs.webkit.org/show_bug.cgi?id=217934