Bug 21784 - [GTK] Make layout tests / jsc tests usable without build-webkit
Summary: [GTK] Make layout tests / jsc tests usable without build-webkit
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Minor
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2008-10-22 00:14 PDT by Alp Toker
Modified: 2009-04-27 08:10 PDT (History)
1 user (show)

See Also:


Attachments
set the product dir to the value of WEBKITOUTPUTDIR (1.53 KB, patch)
2009-03-20 16:50 PDT, Jan Alonzo
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alp Toker 2008-10-22 00:14:52 PDT
The build-webkit script is rarely used by GTK+ port developers as the port uses autotools.

The DRT and JavaScriptCore test drivers currently expect the built products (binaries) to be where build-webkit puts them, which is fine and useful for the build bot harness. This is not a good default for most developers though.

I've had some success with this command line:

~/Projects/webkit/ng/build$ ../webkit/WebKitTools/Scripts/run-webkit-tests --root=. --gtk --strict

I don't remember the command to run the JS tests off hand, but it was similar. This is probably very non-obvious to casual WebKit GTK+ contributors (and distribution packagers, for whom we need to make it really easy to run the tests before they ship their binaries).

I think the output directory of results was also not ideal (maybe it was littering srcdir?).

We need to modify the scripts to make this more obvious and/or document the correct invocation of the commands for this use case.
Comment 1 Alp Toker 2008-10-24 22:50:09 PDT
I can't actually get run-webkit-tests to work at all right now. The gtk/DumpRenderTree binary works fine when invoked directly, but the run-webkit-tests perl script seems not to be working. One guess is that it's scrubbing important environment variables that need to be defined.
Comment 2 Alp Toker 2008-10-24 22:56:44 PDT
(In reply to comment #1)
> I can't actually get run-webkit-tests to work at all right now. The
> gtk/DumpRenderTree binary works fine when invoked directly, but the
> run-webkit-tests perl script seems not to be working. One guess is that it's
> scrubbing important environment variables that need to be defined.
> 

It works with webkitdirs.pm and run-webkit-tests from r35816, so appears to be a regression that showed up in the perl scripts since 2008-08-18.
Comment 3 Jan Alonzo 2009-03-20 16:50:26 PDT
Created attachment 28810 [details]
set the product dir to the value of WEBKITOUTPUTDIR 

This requires WEBKITOUTPUTDIR pointed to the location of the build directory - doesn't work with relative paths currently.

e.g.

WEBKITOUTPUTDIR=~/WebKit/build ./WebKitTools/Scripts/run-webkit-tests --gtk .....
Comment 4 Gustavo Noronha (kov) 2009-04-27 06:43:43 PDT
Comment on attachment 28810 [details]
set the product dir to the value of WEBKITOUTPUTDIR 

Like I said on IRC, as long as this keeps working with build-webkit builds, r=me, with a less confusing comment ;D.
Comment 5 Jan Alonzo 2009-04-27 08:10:11 PDT
Landed in r42891