Bug 217538 - [ iOS Debug ] imported/w3c/web-platform-tests/mediacapture-record/MediaRecorder-stop.html is a constant timeout
Summary: [ iOS Debug ] imported/w3c/web-platform-tests/mediacapture-record/MediaRecord...
Status: RESOLVED DUPLICATE of bug 196403
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2020-10-09 16:12 PDT by Hector Lopez
Modified: 2020-12-18 05:59 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hector Lopez 2020-10-09 16:12:26 PDT
imported/w3c/web-platform-tests/mediacapture-record/MediaRecorder-stop.html

Test is a constant timeout on iOS Debug according to history. First occurrence of a timeout is at r267847. 

History:

https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Fmediacapture-record%2FMediaRecorder-stop.html&platform=ios&style=debug

Stderr:

(generic_decoder.cc:92): Too many frames backed up in the decoder, dropping this one.
(rtp_rtcp_impl.cc:312): Failed to send RTCP BYE
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(RTCVideoEncoderH264.mm:1029): Encode callback failed
(video_receive_stream.cc:721): No decodable frame in 3000 ms, requesting keyframe.
Comment 1 Radar WebKit Bug Importer 2020-10-09 16:12:47 PDT
<rdar://problem/70157646>
Comment 2 Hector Lopez 2020-10-09 16:17:52 PDT
Test expectation while investigated:

https://trac.webkit.org/changeset/268296/webkit
Comment 3 youenn fablet 2020-10-12 05:05:29 PDT
This very often times out but sometimes passes as well.
Comment 4 youenn fablet 2020-10-12 05:07:04 PDT
Even when it is passing, it takes more than 30 seconds.
Let's try marking the test as slow.
Comment 5 Ryan Haddad 2020-12-17 16:33:21 PST
The test was marked as slow and it is now passing (takes ~39 seconds)
Comment 6 youenn fablet 2020-12-18 05:59:18 PST

*** This bug has been marked as a duplicate of bug 196403 ***