Bug 21753 - Large animated GIF image doesn't start animation properly
Summary: Large animated GIF image doesn't start animation properly
Status: RESOLVED DUPLICATE of bug 22995
Alias: None
Product: WebKit
Classification: Unclassified
Component: Images (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://radar.weather.gov/Conus/full_l...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-20 08:05 PDT by Jim Oase
Modified: 2008-12-26 10:25 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Oase 2008-10-20 08:05:39 PDT
This site seems to be a tough test for Webkit.  I am using build r37698 and animation looping no longer works.  Page renders very quickly.
Comment 1 Robert Blaut 2008-12-26 10:04:50 PST
Confirmed. There is something wrong with GIF animation in WebKit. The animation after first loading doesn't start but after restarting WebKit and loading the site from cache gif starts animating.
Comment 2 Robert Blaut 2008-12-26 10:06:45 PST
Opening image in new tab also causes WebKit to start GIF animation on a new tab.
Comment 3 Robert Blaut 2008-12-26 10:25:56 PST

*** This bug has been marked as a duplicate of 22995 ***