Bug 217364 - [macOS] Bump reported current shipping release UA to 10_15_7
Summary: [macOS] Bump reported current shipping release UA to 10_15_7
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 219346 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-05 21:52 PDT by Luming Yin
Modified: 2020-12-01 04:14 PST (History)
8 users (show)

See Also:


Attachments
Patch (1.45 KB, patch)
2020-10-05 22:01 PDT, Luming Yin
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Luming Yin 2020-10-05 21:52:38 PDT
On macOS Catalina 10.15.7, Safari reports platform user agent with OS version 10_15_7. On macOS Big Sur 11.0, Safari reports platform user agent with OS version 10_15_6. It's a bit odd to have Big Sur report an older OS version than Catalina. Bump the reported current shipping release UA from 10_15_6 to 10_15_7.
Comment 1 Luming Yin 2020-10-05 21:53:16 PDT
<rdar://69984962>
Comment 2 Luming Yin 2020-10-05 22:01:01 PDT
Created attachment 410611 [details]
Patch
Comment 3 Alex Christensen 2020-10-05 22:52:24 PDT
We really need a way to do this in a more automated fashion.  I believe this is at least the third time we've had to remember to manually tweak this this release.
Comment 4 Luming Yin 2020-10-05 23:00:05 PDT
(In reply to Alex Christensen from comment #3)
> We really need a way to do this in a more automated fashion.  I believe this
> is at least the third time we've had to remember to manually tweak this this
> release.

I agree. Hopefully this will be the last time we need to manually bump the 
shipping release version before reporting the real 11_x version number to 
websites.

Catalina quality updates are done, so 10.15.7 is the last patch version. 
Security SUs from this point on won’t increment the patch version, and 
does not affect the user agent.
Comment 5 EWS 2020-10-06 01:31:59 PDT
luming_yin@apple.com does not have committer permissions according to https://svn.webkit.org/repository/webkit/trunk/Tools/Scripts/webkitpy/common/config/contributors.json.

Rejecting attachment 410611 [details] from commit queue.
Comment 6 EWS 2020-10-06 10:38:56 PDT
Committed r268058: <https://trac.webkit.org/changeset/268058>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 410611 [details].
Comment 7 Alexey Proskuryakov 2020-11-30 19:48:29 PST
*** Bug 219346 has been marked as a duplicate of this bug. ***