Bug 21728 - svg/custom/use-instanceRoot-as-event-target.xhtml leaks an event listener and associated elements
Summary: svg/custom/use-instanceRoot-as-event-target.xhtml leaks an event listener and...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction, LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2008-10-18 00:43 PDT by mitz
Modified: 2010-01-19 07:50 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2008-10-18 00:43:06 PDT
svg/custom/use-instanceRoot-as-event-target.xhtml reports the following:
LEAK: 1 EventListener
LEAK: 2 WebCoreSVGElementInstance
LEAK: 918 WebCoreNode
LEAK: 1 CachedResource
LEAK: 174 StructureID
LEAK: 292 JSC::Node
Comment 1 mitz 2008-10-18 00:47:35 PDT
Here is a reduction (bugzilla won't accept it as an attachment right now):

<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="100px" height="100px">
  <defs>
      <rect id="target" />
  </defs>
  <use id="test" xlink:href="url(#target)"/>
    <script>
    document.getElementById("test").instanceRoot.addEventListener("mouseover", function() {}, false);
    </script>
</svg>
Comment 2 Nikolas Zimmermann 2010-01-18 20:04:35 PST
Mitz, could you retest in ToT? I can't reproduce it, but like to hear your opinion before closing.
Comment 3 Nikolas Zimmermann 2010-01-19 07:50:53 PST
Can't reproduce it. Closing.