Bug 217003 - Support OES_fbo_render_mipmap
Summary: Support OES_fbo_render_mipmap
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: James Darpinian
URL:
Keywords: InRadar
: 141242 (view as bug list)
Depends on: 215599
Blocks: 216014 141242
  Show dependency treegraph
 
Reported: 2020-09-25 16:50 PDT by James Darpinian
Modified: 2020-10-28 16:34 PDT (History)
15 users (show)

See Also:


Attachments
Patch (26.28 KB, patch)
2020-09-25 16:59 PDT, James Darpinian
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Darpinian 2020-09-25 16:50:59 PDT
Support OES_fbo_render_mipmap
Comment 1 James Darpinian 2020-09-25 16:59:34 PDT
Created attachment 409761 [details]
Patch
Comment 2 Kenneth Russell 2020-09-25 17:05:42 PDT
Comment on attachment 409761 [details]
Patch

Looks good to me. Have you verified locally that the extension test goes down the code path where the extension's enabled? r+
Comment 3 Dean Jackson 2020-09-25 17:06:53 PDT
Comment on attachment 409761 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=409761&action=review

> Source/WebCore/html/canvas/OESFBORenderMipmap.h:33
> +    WTF_MAKE_ISO_ALLOCATED(OESFBORenderMipmap);

Thanks for this. We missed that sub-classes need it in the patch where we added IsoHeap allocation to WebGLExtension and it ended up as the number 1 WebKit crash in iOS 14 :)
Comment 4 James Darpinian 2020-09-25 17:07:19 PDT
Comment on attachment 409761 [details]
Patch

Yes, the extension works locally. Thanks!
Comment 5 EWS 2020-09-25 17:41:41 PDT
Committed r267613: <https://trac.webkit.org/changeset/267613>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 409761 [details].
Comment 6 Radar WebKit Bug Importer 2020-09-25 20:57:00 PDT
<rdar://problem/69609581>
Comment 7 Kenneth Russell 2020-09-25 21:54:30 PDT
(In reply to Dean Jackson from comment #3)
> Comment on attachment 409761 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=409761&action=review
> 
> > Source/WebCore/html/canvas/OESFBORenderMipmap.h:33
> > +    WTF_MAKE_ISO_ALLOCATED(OESFBORenderMipmap);
> 
> Thanks for this. We missed that sub-classes need it in the patch where we
> added IsoHeap allocation to WebGLExtension and it ended up as the number 1
> WebKit crash in iOS 14 :)

I think that was my patch from Bug 215599 - I'm sorry for breaking things!
Comment 8 Alex Christensen 2020-09-26 13:45:57 PDT
http://trac.webkit.org/r267625
Comment 9 Kenneth Russell 2020-10-28 16:34:07 PDT
*** Bug 141242 has been marked as a duplicate of this bug. ***