Bug 21676 - float:left causing misalignment
Summary: float:left causing misalignment
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL: data:text/html,<!DOCTYPE html PUBLIC ...
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-16 14:56 PDT by Anantha Keesara
Modified: 2012-10-02 11:11 PDT (History)
2 users (show)

See Also:


Attachments
reduction.zip (471 bytes, application/octet-stream)
2008-10-16 14:59 PDT, Anantha Keesara
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anantha Keesara 2008-10-16 14:56:25 PDT
I Steps:
Go to http://eat.gd.sina.com.cn/news/2006-06-21/2583136.html
Scroll down to see the content misalgnment on right side of page

II Issue:
in right column, text is going out of column

III Conclusion:
issue is caused by the float:left of the <div> where the images are (in testcase, the <div> with green border)

IV Other Browsers:
IE7: ok
FF3: not ok

V Nightly tested: 37382
Comment 1 Anantha Keesara 2008-10-16 14:59:41 PDT
Created attachment 24429 [details]
reduction.zip
Comment 2 Luke Macpherson 2012-03-14 20:55:14 PDT
This bug is ~3 years old now. Is it still reproducible?
Comment 3 Robert Hogan 2012-10-02 11:11:59 PDT
The rendering you expect here looks like an IE quirk. In strict mode, WebKit, FF, Opera and IE all agree - see the updated url, or: http://roberthogan.net/css/bug21676.html

So this bug is invalid - the behaviour in strict mode is the same for all browsers.