[WebIDL] Split up Performance.idl into component partials
Created attachment 409203 [details]
Created attachment 409204 [details]
Created attachment 409205 [details]
Reviewers, curious to hear feedback on the new naming scheme for this partial supplements. e.g. Performance+UserTiming.idl, etc.
The benefits as I see them are making it clear to someone looking for all the components of a interface and not conflicting with existing interface names (for instance, there is already an interface called PerformanceResourceTiming).
Anyone want to review?
Comment on attachment 409205 [details]
I like these names with + I think.
Created attachment 409356 [details]
Created attachment 409357 [details]
Committed r267408: <https://trac.webkit.org/changeset/267408>
All reviewed patches have been landed. Closing bug and clearing flags on attachment 409357 [details].