Bug 216389 - No audio output when unplugged wired headset during a call
Summary: No audio output when unplugged wired headset during a call
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: Safari 13
Hardware: iPhone / iPad iOS 13
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
: 223182 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-10 17:39 PDT by Trung Le
Modified: 2021-04-02 06:19 PDT (History)
16 users (show)

See Also:


Attachments
Patch (28.75 KB, patch)
2021-03-22 05:33 PDT, youenn fablet
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Patch (28.74 KB, patch)
2021-03-22 06:24 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (28.78 KB, patch)
2021-03-22 07:36 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (28.83 KB, patch)
2021-03-22 08:46 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Patch for landing (28.61 KB, patch)
2021-03-23 03:56 PDT, youenn fablet
no flags Details | Formatted Diff | Diff
Rebasing (28.58 KB, patch)
2021-04-02 03:11 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Trung Le 2020-09-10 17:39:49 PDT
In our webRTC application on iPad, if I unplug a wired headset during a call, I would not be able to hear others in the call anymore. It seems the audio output does not switch automatically from the headset to the iPad speaker.If I use a Bluetooth headset, then the audio output switches automatically to the iPad speaker and i can hear others fine.
I was also be able to reproduce the same issue with other webRTC apps like Google Meet.
Comment 1 Radar WebKit Bug Importer 2020-09-10 23:59:10 PDT
<rdar://problem/68692800>
Comment 2 youenn fablet 2021-03-22 05:33:59 PDT
Created attachment 423874 [details]
Patch
Comment 3 youenn fablet 2021-03-22 06:24:41 PDT
Created attachment 423875 [details]
Patch
Comment 4 youenn fablet 2021-03-22 07:36:41 PDT
Created attachment 423882 [details]
Patch
Comment 5 youenn fablet 2021-03-22 08:46:48 PDT
Created attachment 423890 [details]
Patch
Comment 6 Eric Carlson 2021-03-22 10:36:00 PDT
Comment on attachment 423882 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=423882&action=review

> Source/WebCore/ChangeLog:17
> +
> +

Nit: two blank lines

> Source/WebCore/platform/audio/ios/MediaSessionHelperIOS.h:109
> +private:

Nit: don't need a second `private`

> Source/WebCore/platform/audio/ios/MediaSessionHelperIOS.mm:76
> +

Nit: extra blank line
Comment 7 youenn fablet 2021-03-22 12:47:34 PDT
*** Bug 223182 has been marked as a duplicate of this bug. ***
Comment 8 Eric Carlson 2021-03-22 12:58:08 PDT
Comment on attachment 423890 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=423890&action=review

> Source/WebCore/ChangeLog:17
> +
> +

Nit: two blank lines

> Source/WebCore/platform/audio/ios/MediaSessionHelperIOS.h:109
> +private:

Do we need the second `private:`?

> Source/WebCore/platform/audio/ios/MediaSessionHelperIOS.mm:76
> +

Nit: extra blank line
Comment 9 youenn fablet 2021-03-23 03:56:15 PDT
Created attachment 424010 [details]
Patch for landing
Comment 10 youenn fablet 2021-04-02 03:11:15 PDT
Created attachment 425003 [details]
Rebasing
Comment 11 EWS 2021-04-02 06:19:05 PDT
Committed r275417: <https://commits.webkit.org/r275417>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 425003 [details].