Bug 216323 - kill-old-processes: Avoid calling kill command with empty string with GNU xargs
Summary: kill-old-processes: Avoid calling kill command with empty string with GNU xargs
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Lauro Moura
URL:
Keywords: InRadar
: 215999 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-09 13:35 PDT by Lauro Moura
Modified: 2020-09-13 22:24 PDT (History)
6 users (show)

See Also:


Attachments
Patch (1.56 KB, patch)
2020-09-09 13:38 PDT, Lauro Moura
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Patch for landing (1.58 KB, patch)
2020-09-09 19:33 PDT, Lauro Moura
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lauro Moura 2020-09-09 13:35:07 PDT
Currently, the kill-old-processes command to kill python scripts (like run-webkit-tests) has an unchecked "xargs kill" at the end, which may output an error message if there is no such command to be killed (as it is the case most of the time). Linux' version of xargs has the "-r" option which can be used to avoid running the command.
Comment 1 Lauro Moura 2020-09-09 13:38:02 PDT
Created attachment 408362 [details]
Patch
Comment 2 Darin Adler 2020-09-09 14:06:23 PDT
Comment on attachment 408362 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=408362&action=review

> Tools/ChangeLog:3
> +        kill-old-processes: Avoid calling kill command with empty string

This is a platform-specific bug and fix. On BSD systems like macOS, xargs already doesn’t do this. But on platforms with GNU xargs this "-r" option is needed.
Comment 3 Lauro Moura 2020-09-09 19:33:53 PDT
Created attachment 408402 [details]
Patch for landing
Comment 4 Lauro Moura 2020-09-09 19:35:37 PDT
Committed r266808: <https://trac.webkit.org/changeset/266808>
Comment 5 Radar WebKit Bug Importer 2020-09-09 19:36:20 PDT
<rdar://problem/68612810>
Comment 6 Diego Pino 2020-09-13 22:24:57 PDT
*** Bug 215999 has been marked as a duplicate of this bug. ***