Bug 21616 - Start the debugger without reloading the inspected page
Summary: Start the debugger without reloading the inspected page
Status: RESOLVED DUPLICATE of bug 21345
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Geoffrey Garen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-15 13:08 PDT by Geoffrey Garen
Modified: 2008-10-15 13:34 PDT (History)
0 users

See Also:


Attachments
patch (79.32 KB, patch)
2008-10-15 13:26 PDT, Geoffrey Garen
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2008-10-15 13:08:50 PDT
Patch coming.
Comment 1 Geoffrey Garen 2008-10-15 13:26:05 PDT
Created attachment 24366 [details]
patch
Comment 2 Geoffrey Garen 2008-10-15 13:30:44 PDT
Oops! I forgot that we already had a bug for this.

*** This bug has been marked as a duplicate of 21345 ***
Comment 3 Darin Adler 2008-10-15 13:34:00 PDT
Comment on attachment 24366 [details]
patch

r=me

A couple questions. What about other platforms? Won't this break compiling because of calls to startDebuggingAndReloadInspectedPage() on Windows?

Is there any case where the recompiled function is already in the call chain when this recompiling is done? For example, if you're in a showModalDialog call?