Bug 21589 - High cpu load and slow GIF animation rendering
Summary: High cpu load and slow GIF animation rendering
Status: RESOLVED DUPLICATE of bug 22280
Alias: None
Product: WebKit
Classification: Unclassified
Component: Images (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-14 10:45 PDT by Vilen Tambovtsev
Modified: 2009-09-14 13:56 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vilen Tambovtsev 2008-10-14 10:45:50 PDT
Webkit r37469.
Here is the image: http://cache.boston.com/universal/site_graphics/blogs/bigpicture/sol_10_13/sol09.gif
When I try to open this image in Webkit I'm suffering real high cpu load(50-70%) and slow animation at the same time. If I crawl a web page with some more animations Webkit stops responding at all, for instance this page http://habrahabr.ru/blogs/kosmos/42350/
Comment 1 Vilen Tambovtsev 2008-10-14 10:48:17 PDT
Same image is rendered smoothly in Firefox, and CPU load is 7-10%
Comment 2 Jussi Hagman 2009-02-02 05:23:48 PST
Loooks like #22280.
Comment 3 Douglas 2009-03-05 11:08:27 PST
That's right. GIF animation plays very smooth in Firefox and in QuickTime, but in WebKit-Safari it: 1) hangs browser (10-30 seconds showing rainbow cursor), 2) in beginning of animation, plays almost every frame, but then plays every 5-10th frame only and evenually shows rainbow cursor again.
Power Mac G4 800; OS X 10.4.11; WebKit nightly build (March 4)
Comment 4 Vilen Tambovtsev 2009-07-09 14:41:33 PDT
The page to prove the bug
http://tambovtsev.info/webkit-bug.html
Comment 5 Peter Kasting 2009-09-14 13:56:41 PDT

*** This bug has been marked as a duplicate of bug 22280 ***