Bug 21576 - Fix a race in fast/history/history_reload.html
: Fix a race in fast/history/history_reload.html
Status: RESOLVED FIXED
: WebKit
Tools / Tests
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-10-13 12:34 PST by
Modified: 2008-10-17 11:08 PST (History)


Attachments
Fixed test (1.97 KB, patch)
2008-10-13 12:47 PST, Pam Greene (IRC:pamg)
timothy: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-13 12:34:49 PST
The fast/history/history_reload.html test has a potential race condition caused by higher-resolution timers.  I don't know exactly what threshold it takes to expose the problem, but it's worth removing anyway.

Each time the subframe loads, the onclose handler calls layoutTestController.notifyDone via setTimeout(0). If that gets fired before the history.go() completes, the test appears to have failed.

One solution is to always use two passes in the test, and not complete until the second one.
------- Comment #1 From 2008-10-13 12:47:23 PST -------
Created an attachment (id=24322) [details]
Fixed test

No change to expected results.
------- Comment #2 From 2008-10-17 11:08:06 PST -------
Landed in r37657.