Bug 215726 - REGRESSION(r265975) [GTK][WPE] Two webgl crashes and 1 failure
Summary: REGRESSION(r265975) [GTK][WPE] Two webgl crashes and 1 failure
Status: RESOLVED DUPLICATE of bug 215725
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-20 22:02 PDT by Lauro Moura
Modified: 2020-08-20 22:11 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lauro Moura 2020-08-20 22:02:49 PDT
Crashes:

LayoutTests/fast/canvas/webgl/webgl-compressed-texture-astc.html
webgl/1.0.3/conformance/extensions/get-extension.html

Both when enabling WebGLCompressedTextureASTC. Trace:

Thread 1 (Thread 0x7f18436fc2c0 (LWP 24571)):
#0  0x00007f185c23ad61 in WebCore::WebGLExtension::operator new(unsigned long) (size=32) at ../../Source/WebCore/html/canvas/WebGLExtension.cpp:36
#1  0x00007f185c24a088 in WebCore::WebGLRenderingContext::getExtension(WTF::String const&) (this=0x7effed8fb540, name=...) at ../../Source/WebCore/html/canvas/WebGLRenderingContext.cpp:161
#2  0x00007f185aecff4d in WebCore::jsWebGLRenderingContextPrototypeFunctionGetExtensionBody(JSC::JSGlobalObject*, JSC::CallFrame*, WebCore::JSWebGLRenderingContext*) (lexicalGlobalObject=0x7effedb61068, callFrame=0x7fff48956320, castedThis=0x7effd33ca728) at DerivedSources/WebCore/JSWebGLRenderingContext.cpp:6473
#3  0x00007f185aea4f89 in WebCore::IDLOperation<WebCore::JSWebGLRenderingContext>::call<&WebCore::jsWebGLRenderingContextPrototypeFunctionGetExtensionBody, (WebCore::CastedThisErrorBehavior)0>(JSC::JSGlobalObject&, JSC::CallFrame&, char const*) (lexicalGlobalObject=..., callFrame=..., operationName=0x7f185fa4d0de "getExtension") at ../../Source/WebCore/bindings/js/JSDOMOperation.h:53
#4  0x00007f185aea4c64 in WebCore::jsWebGLRenderingContextPrototypeFunctionGetExtension(JSC::JSGlobalObject*, JSC::CallFrame*) (lexicalGlobalObject=0x7effedb61068, callFrame=0x7fff48956320) at DerivedSources/WebCore/JSWebGLRenderingContext.cpp:6478
#5  0x00007f1802a87178 in  ()
#6  0x00007fff489563b0 in  ()
#7  0x00007f184a961650 in llint_op_call () at /app/webkit/WebKitBuild/Debug/lib/libjavascriptcoregtk-4.0.so.18
#8  0x0000000000000000 in  ()

Failure:

webgl/1.0.3/conformance/context/context-lost-restored.html

--- /home/buildbot/worker/gtk-linux-64-release-tests/build/layout-test-results/webgl/1.0.3/conformance/context/context-lost-restored-expected.txt
+++ /home/buildbot/worker/gtk-linux-64-release-tests/build/layout-test-results/webgl/1.0.3/conformance/context/context-lost-restored-actual.txt
@@ -41,17 +41,17 @@
 [ 38: PASS ] getError was expected value: NO_ERROR : after evaluating: gl.bindTexture(gl.TEXTURE_2D, texture)
 [ 39: PASS ] getError was expected value: NO_ERROR : after evaluating: gl.useProgram(program)
 [ 40: PASS ] getError was expected value: NO_ERROR : after evaluating: gl.bindBuffer(gl.ARRAY_BUFFER, bufferObjects[0])
-[ 41: FAIL ] getError expected: INVALID_ENUM. Was NO_ERROR : after evaluating: gl.texImage2D(gl.TEXTURE_2D, 0, gl.RGBA, 1, 1, 0, gl.RGBA, gl.FLOAT, null)
-[ 42: PASS ] newExtension != null is true
-[ 43: FAIL ] newExtension.webglTestProperty === undefined should be true. Was false.
-[ 44: PASS ] getError was expected value: NO_ERROR : after evaluating: gl.texImage2D(gl.TEXTURE_2D, 0, gl.RGBA, 1, 1, 0, gl.RGBA, gl.FLOAT, null)
-[ 45: FAIL ] OES_vertex_array_object.createVertexArrayOES() should be null. Was [object WebGLVertexArrayObjectOES].
-[ 46: PASS ] newExtension != null is true
-[ 47: FAIL ] newExtension.webglTestProperty === undefined should be true. Was false.
-[ 48: PASS ] OES_vertex_array_object.createVertexArrayOES() != null is true
-[ 49: FAIL ] old_OES_vertex_array_object.createVertexArrayOES() == null should be true. Was false.
+[ 41: PASS ] getError was expected value: INVALID_ENUM : after evaluating: gl.texImage2D(gl.TEXTURE_2D, 0, gl.RGBA, 1, 1, 0, gl.RGBA, gl.FLOAT, null)
+[ 42: FAIL ] newExtension != null should be true. Was false.
+[ 43: FAIL ] newExtension.webglTestProperty === undefined should be true. Threw exception TypeError: undefined is not an object (evaluating 'newExtension.webglTestProperty')
+[ 44: FAIL ] getError expected: NO_ERROR. Was INVALID_ENUM : after evaluating: gl.texImage2D(gl.TEXTURE_2D, 0, gl.RGBA, 1, 1, 0, gl.RGBA, gl.FLOAT, null)
+[ 45: PASS ] OES_vertex_array_object.createVertexArrayOES() is null
+[ 46: FAIL ] newExtension != null should be true. Was false.
+[ 47: FAIL ] newExtension.webglTestProperty === undefined should be true. Threw exception TypeError: undefined is not an object (evaluating 'newExtension.webglTestProperty')
+[ 48: FAIL ] OES_vertex_array_object.createVertexArrayOES() != null should be true. Threw exception TypeError: undefined is not an object (evaluating 'OES_vertex_array_object.createVertexArrayOES')
+[ 49: PASS ] old_OES_vertex_array_object.createVertexArrayOES() == null is true
 [ 50: PASS ] newExtension != null is true
 [ 51: PASS ] newExtension.webglTestProperty === true is true
 [ 52: PASS ] successfullyParsed is true
-[ FAIL ] 5 failures reported
+[ FAIL ] 6 failures reported
Comment 1 Lauro Moura 2020-08-20 22:11:56 PDT

*** This bug has been marked as a duplicate of bug 215725 ***