Bug 215289 - AudioContext / OfflineAudioContext should support a wider sample rate range
Summary: AudioContext / OfflineAudioContext should support a wider sample rate range
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Audio (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks: 212611 215301
  Show dependency treegraph
 
Reported: 2020-08-07 13:11 PDT by Chris Dumez
Modified: 2020-08-07 17:38 PDT (History)
13 users (show)

See Also:


Attachments
Patch (323.76 KB, patch)
2020-08-07 14:15 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (326.39 KB, patch)
2020-08-07 14:49 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (326.48 KB, patch)
2020-08-07 14:53 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (333.21 KB, patch)
2020-08-07 15:37 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (333.00 KB, patch)
2020-08-07 16:36 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (333.93 KB, patch)
2020-08-07 17:11 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2020-08-07 13:11:26 PDT
AudioContext / OfflineAudioContext should support a wider sample rate range. A lot of WPT tests are failing because we support a much smaller range of sample rates than other browsers.
Comment 1 Chris Dumez 2020-08-07 14:15:22 PDT
Created attachment 406211 [details]
Patch
Comment 2 Eric Carlson 2020-08-07 14:31:57 PDT
Comment on attachment 406211 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=406211&action=review

> Source/WebCore/Modules/webaudio/BaseAudioContext.cpp:108
>  bool BaseAudioContext::isSampleRateRangeGood(float sampleRate)

This isn't new, but`isSampleRateRangeGood` isn't a great name. What is a "good" sample rate, one that renders natively, or one that sounds good, or ...
 
`isSampleRateSupported` or `isSupportedSampleRate` would be a better name.
Comment 3 Chris Dumez 2020-08-07 14:49:49 PDT
Created attachment 406215 [details]
Patch
Comment 4 Chris Dumez 2020-08-07 14:53:53 PDT
Created attachment 406217 [details]
Patch
Comment 5 Chris Dumez 2020-08-07 15:37:21 PDT
Created attachment 406220 [details]
Patch
Comment 6 Chris Dumez 2020-08-07 16:36:34 PDT
Created attachment 406225 [details]
Patch
Comment 7 Chris Dumez 2020-08-07 17:11:45 PDT
Created attachment 406230 [details]
Patch
Comment 8 EWS 2020-08-07 17:37:16 PDT
Committed r265403: <https://trac.webkit.org/changeset/265403>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 406230 [details].
Comment 9 Radar WebKit Bug Importer 2020-08-07 17:38:19 PDT
<rdar://problem/66708087>